cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

How to restrict the People Picker Control (on Mobile Apps) to a specific SharePoint Group

Jump to solution

How to restrict the People Picker Control (on Mobile Apps) to a specific SharePoint Group.

We're running SharePoint 2013 on Prem.

I'm able to get the Desktop version of Nintex forms to respect the restriction but the Mobile App doesn't seem to do so.

The TESTGroup (SharePoint group) contains 2 people. With the above settings, I want to be able to select from only those 2 people (actual application will be ~500 people).

Desktop people picker correctly resolves only those 2 entries.

Unfortunately, the mobile app people picker still searches the entire forest.

0 Kudos
Reply
2 Replies
Workflow Hero

Re: How to restrict the People Picker Control (on Mobile Apps) to a specific SharePoint Group

Jump to solution

Hi Jan, 

Are you using Responsive Forms or the Classic designer in your form design? 

I want to test between a connected people control (using the column settings in the list) and a control that has the SharePoint Group filtering in the control settings:

Thank you,

Sean 

Reply
Highlighted
Workflow Hero

Re: How to restrict the People Picker Control (on Mobile Apps) to a specific SharePoint Group

Jump to solution

We are using Classic. I should mention that our version of forms is a wee bit (a lot) out of date 2.9.0.0 (I'm looking to do an upgrade soon)

Interesting. An unconnected PeoplePicker control has the filter.

When I connect it to the Person field in my list, the option goes away.

Thank you Sean,

Now how do I place the value of the unconnected control into the connected one if I can't use javascript in the mobile app?


Further Update

I've gone and tried creating a column directly from the Nintex Form designer with the correct filtering right from the start, and the filtering works.

So my issue is only that Nintex Mobile form doesn't correctly pick up the settings if they are not setup initially that way. (or it could be SharePoint just doesn't update the property correctly?)

Final Update (Found the solution)

Ok, so it's actually a really simple solution. Nintex form does not update the settings when they're changed if the control is already on the form. When changing the filtering, it seems necessary to remove the control off the form and then re-add it again. This then correctly works in the mobile app when published. Thank you Sean for setting me on the right path.

Reply