cancel
Showing results for 
Search instead for 
Did you mean: 
Nintex Newbie

Create Item Action does not fill Metadata

I created a Workflow on a SharePoint list which creates a new Document in an other Library. Based on List-Item Metadata the fields on new created document should be filled up. This works perfect, as long as I start the Workflow manually. As soon as I try to start this Workflow out of an other Workflow on the same list with "Start Workflow"-Action the Document will be created but the Metadata stays empty.

Both Workflows ends successfully with no error-messages. No specific entries in ULS.

Ideas wouldn't go amiss...
Regards Greg

Labels: (1)
Tags (1)
0 Kudos
Reply
3 Replies
Highlighted
Nintex Newbie

Re: Create Item Action does not fill Metadata

Hi @Gregory,

When triggered from Workflow A, have you checked in Workflow B what the ID is from which to copy metadata (use Log History action)? If both are workflows in the same list, "Current Item" references should still work. Also, are you using the Start workflow action or a Web Request to NintexWorkflows.asmx to start a workflow. In which case you need to specify the (Current) Item ID in the call (2nd parameter).

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Create Item Action does not fill Metadata

Hi jpmhuls
Thank you for your Answer. I trigger Workflow B from Workflow A with Start Workflow Action. Both Workflows run on the same List. I try to rebuild Solution in a Testenvironment with kind of simpler Workflow but with the same structure and workflow Actions. On this Testcase the Dokument-Creation runs perfect with wirting Metadata to the new document in the library. Get a hint from a collegue that maybe, it is some premission issue, so I let the Start-Workflow Action and Workflow B under Workflow Owner Permission. Problem still occures. :-(

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Create Item Action does not fill Metadata

Hi,

Has there been a response from Nintex on this question?

0 Kudos
Reply