darrenfloyd666

Set Field value action not finding Library fields

  • This should be easy.

    I just want to set a field called 'View Change' to '1' but when I click on 'Set' on the action I don't get the fields I need from the Sharepoint library. I've done this before on other workflows, just pointed the Set Field action to the field in the Sharepoint list. Is it because I'm using a Library? 

    Instead I get 'Content Type/IS Reference Number/Name/Title'.

     IS Ref is one of the fields in the library. What am I doing wrong?  

    I'm using Nintex cloud and Sharepoint 2016

Tags (1)
0 Kudos
Reply
9 Replies
jpmhuls
Communicator

Re: Set Field value action not finding Library fields

Did you maybe create a reusable workflow (for the wrong content type)?

0 Kudos
Reply
darrenfloyd666

Re: Set Field value action not finding Library fields

I don't know. How would I find out?

0 Kudos
Reply
jpmhuls
Communicator

Re: Set Field value action not finding Library fields

Normally I would check the Workflow Settings page. If it's a reusable, then there should be a disabled Content Types setting showing which content type the workflow is intended for. And reusable workflows are created via the same Nintex menu where you also create Site workflows..

0 Kudos
Reply
darrenfloyd666

Re: Set Field value action not finding Library fields

Hi Jean

I've checked and can't see the Content Types setting. What I can see is below. I clicked on Association Columns, added a Test column and it showed up in the Set Drop down in the Set Field Value action.

0 Kudos
Reply
jpmhuls
Communicator

Re: Set Field value action not finding Library fields

Yes, but that will add a new column to your list as well. Unless that is what you want. And what if you try to use Update Item instead? Using the list and filter on ID = Lookup/Current Item/ID? would that allow you to see the fields?

0 Kudos
Reply
darrenfloyd666

Re: Set Field value action not finding Library fields

Cheers Jean, I'll give it a go.

0 Kudos
Reply
llyehock
Scholar

Re: Set Field value action not finding Library fields

@jpmhuls I have a reusable site collection workflow based on all content type, the only value that I can check is "Content type", it does not show me the user defined fields that I have created for each of the content type. I need the reusable workflow to detect if the "Approver" field in my content type has any value before proceeding to sending an email to the Approver. Wonder how do I get the user defined fields to show up in reusable site collection workflows?

0 Kudos
Reply
jpmhuls
Communicator

Re: Set Field value action not finding Library fields

Do you have proper permissions on the library?

 

NB: If a column is hidden, it also wouldn't show in the list of available columns (most likely not the issue regarding here).

0 Kudos
Reply
llyehock
Scholar

Re: Set Field value action not finding Library fields

I have full rights to the doc library. I am able to see the list of fields belonging to the "current item" option when I create simple workflow, but unable to see this in the reusable workflow that is applying to all content type. Is this by design?

0 Kudos
Reply