tulip
Scholar

Newbie, problem updating managed metadata fields using Call Web Service Action

Hi All,

I am using SharePoint 2010.

I have a Document library with one content type from the Content type hub.  The Content type has 4 managed metadata fields.  I want to update those metadata fields.

I am using the Call Web Service Action.

This is the first time I have used this web service and am really a newbie with Nintex - so please bear with me.

I am starting small and trying to update only one of the metadata fields as a test.

My column is called Category Category  (I have looked at the internal name and it is Category_x0200_Category)

I understand I need to update the Taxonomy Note field too - which I think is the field Category Category_0 ( the internal name displayed for that is a GUID h9433f21298d47cdb84111a4e6adb06a)

I have tried a number of options for my SOAP (see below) - this works correctly...

<?xml version="1.0" encoding="utf-8"?>

<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:m="http://schemas.microsoft.com/sharepoint/soap/">

  <soap:Header>

  </soap:Header>

  <soap:Body>

    <m:UpdateListItems>

      <m:listName>{F4492B35-780B-437C-B1F4-0064D1FD3199}</m:listName>

<m:updates>      

          <Batch OnError="Continue" ListVersion="1" ViewName="">

            <Method ID="1" Cmd="Update">

              <Field Name="ID">1877</Field>

               <Field Name="TempWFStatus">

<![CDATA[{WorkflowVariable:Val_UpdateText}]]>

</Field>

          </Method>

</Batch>

</m:updates>

    </m:UpdateListItems>

  </soap:Body>

</soap:Envelope>

If I try and add the following

              <Field Name="Category Category"><![CDATA[{WorkflowVariable:Var_CategoryTxt}]]></Field>

               <Field Name="Category Category_0"><![CDATA[{WorkflowVariable:Var_CategoryText_0}]]></Field>              

OR the following

              <Field Name="Category_x0200_Category"><![CDATA[{WorkflowVariable:Var_CategoryTxt}]]></Field>

               <Field Name="{h9433f21298d47cdb84111a4e6adb06a}"><![CDATA[{WorkflowVariable:Var_CategoryText_0}]]></Field>

I get the error

            <ErrorCode>0x81020014</ErrorCode>

            <ErrorText>One or more field types are not installed properly. Go to the list settings page to delete these fields.</ErrorText>

The columns are coming from the content type and I believe are correct - so I really don't want to delete and re-add.

Could someone please point me in the correct direction.

Thank you.

Catharine

0 Kudos
Reply
2 Replies
cju
Scout

Re: Newbie, problem updating managed metadata fields using Call Web Service Action

I maybe answer a bit late but I think that this answer can help :

Re: Write Managed Metadata Field Values with Nintex Workflow

SharePoint Manager is very useful to get the internal name of a column.

Hope this helps

Reply
jflong
Novice

Re: Newbie, problem updating managed metadata fields using Call Web Service Action

Did you ever get a resolution to this error?  I'm working on a similar workflow and getting the same error.  I went as far as creating a new term set and document library just for a proof of concept, but still get the same error:

0x81020014One
or more field types are not installed properly. Go to the list settings page to
delete these fields.

The article referencing the internal name does not apply since I'm using the GUID already from the internal name.

Thanks,

Joe Long

Reply