burkslm
Novice

Create Site

Jump to solution

I want to use the 'Create Site' action. I've never used it before and I'm trying to fix a problem with a workflow that already existed. So, I have Nintex 2010 and SharePoint 2013.

The 'Title' field is the name of what I want to call the new site. Let's say it is called 'New Site'. I want the site to show the site name 'New Site' but I don't want any spaces in the url. The site I create will have the Team site template. This site will be a subsite of the current site. Please tell me how to fill out the action.

Lisa

0 Kudos
Reply
12 Replies
kapilkjoshi
Apprentice

Re: Create Site

Jump to solution

Hi Lisa,

To remove spaces from the Title field you can use regular expression action. Add patter as \s leave the replacement text empty, and the input string will be your title.

Then use this variable in the URL name of the Create Site action. All other field on this action should be clear.

But are you really using Nintex 2010 with SP 2013? How?

0 Kudos
Reply
burkslm
Novice

Re: Create Site

Jump to solution

Can you please give me an example of this. My co-worker was using a replace function and kept getting invalid character.

0 Kudos
Reply
kapilkjoshi
Apprentice

Re: Create Site

Jump to solution
0 Kudos
Reply
burkslm
Novice

Re: Create Site

Jump to solution

Same error:

Failed to create site. "LisaTest3

" contains invalid character '

0 Kudos
Reply
kapilkjoshi
Apprentice

Re: Create Site

Jump to solution

Can you show us the configuration of Create Site action. It could also be the url of your parent site that may be causing this issue.

0 Kudos
Reply
mapeacock
Rookie

Re: Create Site

Jump to solution

Hi Lisa,

I have done this (albeit - in Nintex 2013), using the replace control without issue:

We prefix the site with the ID, but not necessary in your case.

Followed by an update item:

The actual value above is cut off, but should read:

WebURL/CleanSiteName, SiteName

I hope that helps.

Cheers,

Mark

Reply
burkslm
Novice

Re: Create Site

Jump to solution

CreateSite.jpg

0 Kudos
Reply
burkslm
Novice

Re: Create Site

Jump to solution

RegExp.jpg

0 Kudos
Reply
burkslm
Novice

Re: Create Site

Jump to solution

Ok what I said about the Nintex version was wrong. We are running Nintex 2013 but on SharePoint 2010 workflow engine and using SharePoint 2013. Its a mess but that is what is being done.

0 Kudos
Reply