cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

fn-IsMemberOfGroup("Task Team") not working in Nintex Forms 0365

I am trying to enable a multi-line text field only when members from the specific 'Task Team' (example name) access the form. For anyone else accessing the form, the field should stay visible but disabled.

To set this up, I created a multi-line text field, and set the 'Enabled' field to the expression: fn-IsMemberOfGroup("Task Team"). I also added a single-line text field and set the default value to the expression above.

FieldSettings.PNG

However, every time I launch a new form, the single-line text field is recognizing that I'm a member of the group but the multi-line text field stays disabled.

NewForm.PNG

Are there any other settings I need to enable? Am I using the expression incorrectly? I tested this expression in the 'Visible' field as well, with the same results - it hides the field despite me being in the member group.

Labels: (1)
Reply
7 Replies
Workflow Hero

Re: fn-IsMemberOfGroup("Task Team") not working in Nintex Forms 0365

Hi Arti,

Maybe this post can help,

Christophe

0 Kudos
Reply
Not applicable

Re: fn-IsMemberOfGroup("Task Team") not working in Nintex Forms 0365

Hi Christophe, I saw that post before, but we are already using SharePoint groups specific to the site.

0 Kudos
Reply
Workflow Hero

Re: fn-IsMemberOfGroup("Task Team") not working in Nintex Forms 0365

Hey Arti,

did you type the name of the permission group into the inline function in the expression field or did you use copy and paste? I just noticed that the expression doesn't work, when I copy the name of the permission group from the user.aspx page and paste it into the inline function. When I directly type in the name of the permission group everything works as expected!

Best regards,

Jan

Reply
Workflow Hero

Re: fn-IsMemberOfGroup("Task Team") not working in Nintex Forms 0365

Where you able to fix it?

Have you tried to use a rule.

0 Kudos
Reply
Not applicable

Re: fn-IsMemberOfGroup("Task Team") not working in Nintex Forms 0365

Hi Oliver,

Strangely, just like in this thread https://community.nintex.com/thread/2874, it just started working all of a sudden. I am not really sure why it worked again, but I did remove and rebuild that field entirely and as Jan von Reith​ suggested, it's possible I may have typed in the field name instead of copy-pasting it.

Reply
Workflow Hero

Re: fn-IsMemberOfGroup("Task Team") not working in Nintex Forms 0365

Although the behavior is somewhat browser-based, I've noticed that rich-text formatting (bold, italic, colors, etc.) can quite easily find their way into your field properties if you copy/paste from other sources.

Whenever I'm having trouble with CSS classes or JavaScript clientIDs, the first thing I try and do is manually re-type those properties or else you can run into a number of problems.

It's good to hear you got it working Arti A​!

0 Kudos
Reply
Workflow Hero

Re: fn-IsMemberOfGroup("Task Team") not working in Nintex Forms 0365

or maybe you did not put "" around the group name

0 Kudos
Reply