cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

You do not have permission to perform this action or access this resource.

Jump to solution

I'm getting this error on some of the workflows.

HTTP Unauthorized to https://XXXXXXXXXXXXXXXXX/_api/sp.utilities.utility.SendEmail Correlation Id: 699305f2-4667-031b-9c3e-a8cf27d579e1 Instance Id: 57ae7b65-dafa-4fa5-a2d0-7a178013d8a2

Access denied. You do not have permission to perform this action or access this resource.

all the Users in the User Group added with Full Control, some of them not able to receive any notifications when they create an item and when I see the history of the workflow the Task in the workflow is throwing this error, but when I create an item with my login, I’m able to receive the Task assign notification etc..

Any Idea why it's doing that?

Labels: (1)
Tags (1)
0 Kudos
Reply
15 Replies
Automation Master
Automation Master

Re: You do not have permission to perform this action or access this resource.

Jump to solution

This could be a long shot, but I just wanted to at least state that O365 does not send email notifications from workflows outside of the tenant. Could that be possible that a users email address outside the tenant was used somehow?

0 Kudos
Reply
Not applicable

Re: You do not have permission to perform this action or access this resource.

Jump to solution

How can I confirm if the user is within same tenant? I added them in the group of this site. They are able to login and create an item with there login info. Do I have to check any other settings in the site?

Thanks

-Salman

Sent from my Windows Phone

0 Kudos
Reply
Automation Master
Automation Master

Re: You do not have permission to perform this action or access this resource.

Jump to solution

Ok, good info. Is the initiator the user assigned to the task?

0 Kudos
Reply
Not applicable

Re: You do not have permission to perform this action or access this resource.

Jump to solution

Task is assigned to the User Group. Users are in the Group. my login is also the part of the same user group, if i create an Item it move on and send me the Task assign notification.

one information was missing, if i check the History of the Task, it says Task is assigned to the Group, it shows me that in the list. and this morning I got some of the Task notifications for the Items I created yesterday, and when I check the workflow again, the Task is assigned but if I mouse over to the Blue button next to Status it says the same thing.

Next attempt scheduled after 4/18/2015 12:15 AM. Details of last request: HTTP Unauthorized to https://XXXXXXXXXXXXXXX/_api/sp.utilities.utility.SendEmail Correlation Id: 2109e97a-32f3-1c6a-a327-09ef6ce7d2ca Instance Id: bb46ac49-812f-4b2d-8cb1-ca5a6825bac7

Access denied. You do not have permission to perform this action or access this resource.

workflow error2.PNG

0 Kudos
Reply
Not applicable

Re: You do not have permission to perform this action or access this resource.

Jump to solution

also Does this site feature "Workflows can use app permissions" Need to be active? I'm not sure because I'm getting all the notifications, doesn't matter if its on or not.site feature.PNG

0 Kudos
Reply
Automation Master
Automation Master

Re: You do not have permission to perform this action or access this resource.

Jump to solution

Which task action are you using? The Assign a task action can only assign for a single user.

Use Start a Task Process to create tasks on multiple users.

0 Kudos
Reply
Not applicable

Re: You do not have permission to perform this action or access this resource.

Jump to solution

hm.. Assign a Task I'm using. interesting I didn't know that. ok, let me try the Start a Task Action and see how that works. I will keep you posted.

Thanks.

0 Kudos
Reply
Automation Master
Automation Master

Re: You do not have permission to perform this action or access this resource.

Jump to solution

No problem. Within the action, click on the help icon, this will bring up the O365 help documentation that has all of the specific details of the configuration for the action.

0 Kudos
Reply
Not applicable

Re: You do not have permission to perform this action or access this resource.

Jump to solution

I have two users in the User Group, that I added in the Start Task Process. when two users are there, it assign the Task to only one other user not to me and when I check the history, I see one suspended Association Task. when i take out other user email and leave my there, and again run it, than it assigning the Task to me.

workflow startTask.PNG

RequestorId: 484c7eb9-a4eb-ba27-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 400 {"error":{"code":"-2130242040, Microsoft.SharePoint.SPException","message":{"lang":"en-US","value":"The e-mail message cannot be sent. Make sure the e-mail has a valid recipient."}}} {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"X-SP-SERVERSTATE":["ReadOnly=0"],"SPClientServiceRequestDuration":["438"],"DATASERVICEVERSION":["3.0"],"SPRequestGuid":["484c7eb9-a4eb-ba27-9a86-a339766125a1"],"request-id":["484c7eb9-a4eb-ba27-9a86-a339766125a1"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["16.0.0.3912"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Fri, 17 Apr 2015 16:26:07 GMT"],"P3P":["CP=\"ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI\""],"Server":["Microsoft-IIS\/8.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation) Exception from activity Throw If Sequence Sequence TryCatch Sequence Microsoft.SharePoint.WorkflowServices.Activities.RetryForEmail HttpPost Sequence If Sequence Microsoft.SharePoint.WorkflowServices.Activities.Email Sequence Flowchart April 16th workflow Test.WorkflowXaml_ae0c7040_6faf_4ba4_8d09_6283cc536c06

April 16th workflow - was the workflow I had on different list and I also turned it off in the settings before I created new list and Test this new workflow. Can you tell me why this is also showing here and why Start Task Process just using one email out of the User Group. I tried putting two emails in that, and still it just assigned the Task to one user only.

0 Kudos
Reply