cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

Hello,

I am having an issue uploading an image to a Nintex Form on O365. I keep getting a black 'x' in a box anytime I try to upload. Should this image be in JPG? PNG? Are there size restriction? I am placing the image in an image library on a SharePoint and then putting the URL from the image in the URL line. Is this the correct way to do that?

I have tried both PNG and JPG, and a couple different sizes but I cannot get it to display.

Any help is much appreciated! Thank you!

0 Kudos
Reply
10 Replies
Workflow Hero

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

If the image is placed in o365 -> Site Asset library and using the image link in Nintex form should work.

But ensure the image url is got by following steps:

3. Copy the above link and paste in the browser to view the image. You would notice the copied URL would not be the same when the image is viewed. Copy the URL from the browser (where the image is viewed) and use it in Nintex Form:

Can you inspect the black 'x' in the browser designer are share the screen shot?

0 Kudos
Reply
Workflow Hero

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

Hi Jade,

In addition to Chaitra's post, if you want to use Nintex mobile, there are a few other things to do.

Just to make sure there's nothing wrong with your basic setup, go and find a public image on the web and copy its url.  That should be all you need to display the image.  If you've successfully tested that, then we're on to a good thing.

The key concept is your image needs to be available inside and outside your environment for it to display in all situations. 

Luckily for us, our guru Andrew Glasser‌ has done all the hard yards and posted a comprehensive blog on how to access these images using a variety of storage locations.

Cheers,

Chris

Reply
Workflow Hero

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

@Chaitra - I'm still not able to get the image to display even after all of your steps Smiley Sad

I have tried many different versions of the URL link. I have tried the Site Asset Library and also an Images Library and copied the links over to a browser. Do you think it could be that my image is too large? I've tried it both in a JPG and a PNG and neither work. Any help or suggestions you have would be much appreciated!!

Here is my screenshot of the same black box I keep getting:

0 Kudos
Reply
Workflow Hero

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

Can you inspect the image in the browser using Developer Tool (F12) and share a screenshot?

Note: Ensure the URL provided in the Image control, when used in browser displays the image. Share a screenshot of this as well.

0 Kudos
Reply
Workflow Hero

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

Getting the same issue. I've got a picture that's uploaded to a picture library in the same site as the list with the Nintex Form.

Here is a picture of the image showing up correctly in the browser (using Chrome simply so that the whole URL can be seen):

But, here's a picture of the Nintex Form, with the black X. As you can see, I've put in the URL on the right hand side, but there is no URL showing when inspecting element.

What am I missing?

Thanks!!

0 Kudos
Reply
Workflow Hero

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

Is there restricted permission on the image or 'New Image'?

Also, publish the form and inspect the image using Developer Tool as shown below and share the screenshot:

Reply
Workflow Hero

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

UPDATE: I was following Chaitra B C's suggestion to inspect the element after publishing it, and the the image shows up just fine once I published it, exited the editor, and opened the form regularly. 

Here's a mystery though: in Chrome, the image shows up just fine even when editing the form. In I.E., it only shows up after publishing, exiting, and opening as if a regular user. I'm pretty sure it has to do with some vlan restrictions our company has (for PCI compliance) that make I.E. virtually unusable. Bummer is, I've noticed Chrome often crashes working on Nintex forms/workflows, so we're forced to work in I.E. for that. Guess I'll just have to presume the images are working fine until I publish it and check.

In any case, this is solved, unless someone has any reasons they can think that the images don't show up when editing the form in I.E.

Thanks for the quick responses!

Reply
Not applicable

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

Hi, ‌, If you can click "mark correct" on the best reply above, it'll help other community members looking for answeres to similar questions.  And, fyi, I moved this to the ‌ space because it seemed like it belongs there. If you're not using NWF for O365, let me know and I'll move this thread to another area.

Thanks!

Frank

Your community manager

Reply
Workflow Hero

Re: What are the parameters for uploading an image on a Nintex Form in O365?

Jump to solution

Hello ! I marked it as helpful, but I can't find out how to mark it as correct, since I'm not the one who started the thread. Or am I missing something?

Reply