cancel
Showing results for 
Search instead for 
Did you mean: 
jkweaver
Nintex Newbie

Validation Rules for List Lookup results not working

Jump to solution

Was reading through several posts as I am searching for a solution that involves a List Lookup and validation rule. My situation is just slightly different, but very close to some of them.

 

I have a List Lookup on my form that has two drop down values (Add New Vehicle and Replacement Vehicle). These each are connected to a panel via a rule to hide/unhide depending on the value selected in the drop down (list lookup). 

 

I added validation rules so that if one selection is made (Add New Vehicle), it should only impact the other (Replacement Vehicle). However, when I test this, the validation rules fire on both selections.

 

Need some expertise from the great Nintex community. Any thoughts?

Labels: (1)
Tags (1)
0 Kudos
Reply
1 Reply
Highlighted
jkweaver
Nintex Newbie

Re: Validation Rules for List Lookup results not working

Jump to solution
Wanted to post that I was able to find the solution. Each of my selections (Year, Make, Model, VIN, and Coverage) are firing a validation rule for two things: blank response and dependent on the list lookup field selection (Add New Vehicle or Replacement Vehicle). Since this is a list lookup and not a choice list, I wasn't providing the specific lookup value, which would include in my case 1;#.

In the end the correct (and working) validation rule looks like this: isNullOrEmpty({Self})&&VehicleRequestType!="1;#Add New Vehicle"
0 Kudos
Reply