cancel
Showing results for 
Search instead for 
Did you mean: 
req93662
Nintex Newbie

v15.0.1 FoxHub Triggering - BotFlow completes, but not really......

Jump to solution

I have installed v15.0.1 and am testing all my scripts after converting to new .rpa versions.  I have 4 triggers set up in v14.6.2 which work flawlessly.  In testing these 4 triggers in 15.0.1, I notice that a BotFlow will complete and close, but does NOT change to a status of "completed" in the RUNNING queue of FoxHub.  If I simply right-click to stop the BotFlow in the RUNNING queue and then delete it, it does NOT actually delete it and it continues to run in the background.  I have to go to Task Manager to end it.  This does not happen every time, but I cannot identify any pattern for the inconsistency.  Has anyone else experienced this issue with v15.0.1?

Additionally, I see on Foxtrot Alliance that v15.0.2 is already out.  When will that be available for U.S. customers and will that version possibly fix this issue?

Thank you,

Brian

0 Kudos
Reply
5 Replies
mbalslow
Nintex Newbie

Re: v15.0.1 FoxHub Triggering - BotFlow completes, but not really......

Jump to solution

Hi Brian,

How do you "close"/"end" the botflows? E.g. do you use the "Close Me" action or simply let it run to the end and have the FoxHub close the robot after the flow is completed?

0 Kudos
Reply
req93662
Nintex Newbie

Re: v15.0.1 FoxHub Triggering - BotFlow completes, but not really......

Jump to solution

Thanks so much for the reply.

 

I use the "Close Me" action.  The BotFlow always works and closes as expected.  Sometimes it will "complete" in the RUNNIG queue and sometimes it will not.  There is no discernible pattern or cause for the inconsistency.  Even if I stop/delete it in the RUNNING queue, it still runs in the background.  In v14.6.2, if a script ever stopped or was hung up in a running state, if I simply stopped it in the RUNNING queue and then deleted it, I was good.  FoxBot would not continue running in the background, which is what I see happening here, only it's Foxtrot, not FoxBot.  Could it have anything to do with the fact that v14.6.2 separates Foxtrot and FoxHub(FoxBot), while v15.0.1 does not and it is a BotFlow whether executed from FoxHub or Foxtrot? 

0 Kudos
Reply
mbalslow
Nintex Newbie

Re: v15.0.1 FoxHub Triggering - BotFlow completes, but not really......

Jump to solution

Hi Brian,

Okay, unfortunately, this is a bug with the "Close Me" action. The bug should be fixed in version v15.0.2, a version you are welcome to download and install. The reason it is not "fully" published is due to the fact that some of the new actions introduced proved to have some issues, so a v15.0.3 is currently in the works to improve that.

Nevertheless, as explained in our guide on how to use the FoxHub, I would strongly recommend that you do not use the "Close Me" action, instead, use the "Go to End" action to close/end your BotFlow. When executed via the FoxHub, the bot/Foxtrot application will automatically close itself after approx 60 seconds if no other jobs are in the queue.

0 Kudos
Reply
req93662
Nintex Newbie

Re: v15.0.1 FoxHub Triggering - BotFlow completes, but not really......

Jump to solution
Mathias,
Thank you for the exchange of information on my post. One outstanding question I have...…...is your recommendation to NOT use the "Close Me" action only relevant to v15.0.1 bug? Or is that your standard recommendation? I tested your recommendation in v14.6.2 and see that it works, but I remain partial to the "Close Me" action, so will look forward to seeing the bug fixed. Thanks, again.
0 Kudos
Reply
mbalslow
Nintex Newbie

Re: v15.0.1 FoxHub Triggering - BotFlow completes, but not really......

Jump to solution

Hi Brian,

 

Yes, regardless of the bug, I would always recommend using the "Go to End" to 'end' your botflow, not use the "Close Me" action.

0 Kudos
Reply