ekyaw
Novice

Smart Actions is not working

Hi,

 

Replying the task notification email to the service account with "Approve" text. The email went to the service account inbox. however there is no email reply to the user and task is not approved. How can i troubleshoot the issue? 

0 Kudos
2 Replies
boringNerd1
Apprentice

Re: Smart Actions is not working

Hi,

 

I have recently encountered something similar. Everything seems to be working fine, and no errors are being reported. Here's what I did:

 

1. Enable host server logging

 

2. Send a SmartAction reply again

 

3. Check latest HostServer log. Found an entry with a warning about spam. Turns out there is no error reported because this is not an error.

 

4. Followed the guide here to disable spam security. I added the following in my K2HostServer.exe.config, and restart K2 blackpearl service:

 

<system self="K2:DENALLIXK2Service" enableListeners="true" allowAmbiguity="true">

        <security spamSecurity="Off"> <!-- Default is InternalMail. -->

          <!-- A list of trusted domains that are checked against the RECEIVED-FROM header. -->

          <authorizedDomains>

            <add domain="*.denallix.com" />

          </authorizedDomains>

        </security>

    </system>

 

You may want to play around with the spam security settings so that it meets your security requirements.

0 Kudos
ekyaw
Novice

Re: Smart Actions is not working

Thanks. No error related to the smartaction is found. 

 

I found that there is Standard - Exchange Integration Permission error after running analysis. I posted another post as well. Do you face that same issue?

 

http://community.k2.com/t5/K2-blackpearl/Standard-Exchange-Integration-Permissions/m-p/95963#M30984 

 

Thanks again.

0 Kudos