nsterwald78
Novice

Removing the thousandths separator when the double-click to edit event is raised?

Jump to solution

Hello!

 

I noticed that even when you specify to not use the thousandths separator on a list view, when making the "Double-click row to edit (default)" option available, when the field is in edit mode, the thousandths separator is present.

 

I've tried all sensable format options (Making the SO property Text Type, using custom formatting on the field etc.)

 

Anyone have any suggestions?  I'm dealing with account numbers in this list, so seeing the "," is not viable when editing a row.  I'd rather not design a subview just to edit a field 😛

 

Let me know, thanks!


after_dblclick_to_edit_2760.jpg
0 Kudos
Reply
2 Replies
tin
Apprentice

Re: Removing the thousandths separator when the double-click to edit event is raised?

Jump to solution

Hello,


 


Usually an editable list view is made up of the 'display section' and the 'editable section'.  When double clicking on a row, you are interacting with the editable section.


5622i109C22D8A6EB2E3B.png


 


Was the 1000 separators also disabled for the control of the editable row?  This is done so by select the control in question and editing the custom style that is applied:


 


5623iE8E5D79F289F4FCA.png

Reply
nsterwald78
Novice

Re: Removing the thousandths separator when the double-click to edit event is raised?

Jump to solution

Thank you so much, that was it!  I wasn't aware that was how you can apply styles to that "Mode" as I was calling it.

 

thanks again!

0 Kudos
Reply