BryanPeters
Apprentice

HTTP Error 401.2 - Unauthorized K2 Workspace

Jump to solution

Server 2012 R2

Development Server

First Time Install

 

After install when trying to access the Workspace site we receive an error 401.2 - Unauthorized. We are using NTLM Windows authentication. For the K2 Workspace site in IIS authentication is set to ASP.NET Impersonation. Anonymous is disabled as well as Form Authentication. In the event logs for K2 we do not see anything. Does anyone have any ideas what may be causing this or how to resolve it?

 

Can provide additional information.

0 Kudos
5 Replies
JimmyBourque
Apprentice

Re: HTTP Error 401.2 - Unauthorized K2 Workspace

Jump to solution

Hi Bryan,

 

Typically that error will occur if you try to browse to the root of the site as there is no authentication enabled there.  If you expand the site in IIS and click on Workspace then authentication you should see that only Windows Authentication is enabled there.  Add /workspace to the end of the URL and it should come up as expected. 

 

For example, in my environment https://k2.domain.com is the URL for my workspace site.  If I browse to https://k2.domain.com I will get the same error but if I browse to https://k2.domain.com/workspace I will be able to get into workspace without issue.

 

Please let me know if this helps.

 

 

Thanks,

 

Jimmy

BryanPeters
Apprentice

Re: HTTP Error 401.2 - Unauthorized K2 Workspace

Jump to solution

I did as you said and received a 404 error stating the file is unavailable. The path for the file is c:inetpubwwwrootworkspace. I did check and the path does not exist. Do you think I should just run a repair or a re-install? Just to give you some background I did delete the default IIS site and recreate it. This deleted the Workspace directory from wwwroot when I did this. Do you think I should reinstall IIS Manager before doing a repair?

 

Thanks in advance.

0 Kudos
JimmyBourque
Apprentice

Re: HTTP Error 401.2 - Unauthorized K2 Workspace

Jump to solution

Hi Bryan,

 

Okay, that explains why it isn't working.  The workspace applicaiton underneath the K2 site should actually be pointing to the installation directory (C:Program Files (x86)K2 blackpearlWorkSpaceSite).  I would recommend completely uninstalling K2 BlackPearl and deleting the site in IIS again.  You shouldn't need to uninstall/reinstall IIS.  Once BlackPearl has been uninstalled and the server has been rebooted you should be able to reinstall without further issue.

 

 

Jimmy 

BryanPeters
Apprentice

Re: HTTP Error 401.2 - Unauthorized K2 Workspace

Jump to solution

Thanks a million! I am working on a fresh install as we speak. Thanks for the input.

0 Kudos
Mikhail2
Apprentice

Re: HTTP Error 401.2 - Unauthorized K2 Workspace

Jump to solution

As per K2 documentation: K2 Workspace does not function if IIS is not configured correctly. Configure the IIS application pool Managed Pipeline mode setting to Classic and ensure that:  


 



  • Windows Authentication is enabled

  • Anonymous authentication is disabled


I've run into the same error on fresh install of K2 just because Windows Authentication IIS role feature was not installed, hence K2 setup manager can't enable it for you. Refer to the following section of K2 documentation for list of required IIS role features - Required IIS settings for K2 blackpearl


 

0 Kudos