Sharpharp1
Apprentice

GetUsersByGroup Filter error: Object reference not set to an instance of an object

Hi,

 

Happy new year everyone!!!

 

Just started getting this...

 

Message: Object reference not set to an instance of an object.; ServiceName: ADService2; ServiceGuid: 83ac8763-ab*personal details removed*f*personal details removed*bc8-9bde8729b735; InnerExceptionMessage: ;

 

Using the tester tool if i use the getusersbygroup method, then execure, the results are fine, however if i add a filter on department = "a value" then it fails with the above error....

 

It also fails on the form process, so i guess if the test tool doesn't like it, then theres a problem...

 

I tested on a different server and the Result with filter works fine....

 

Any ideas?

0 Kudos
Reply
2 Replies
khanh1
Apprentice

Re: GetUsersByGroup Filter error: Object reference not set to an instance of an object

Hi,


 


Perhaps the working environment has some additional fixes that you might not aware of it. You can check the [Hostserver].[UpdateHistory] table if K2 version is 4.7. I remember there was a known issue in 4.7 with GetUsersByGroup method, it would not work correctly when passing in a filter. I believe this is already fixed with the latest March CU 2018. I would recommend getting the CU if this is the case.


 


 

0 Kudos
Reply
Sharpharp1
Apprentice

Re: GetUsersByGroup Filter error: Object reference not set to an instance of an object

Hi,

 

The first i checked before posting here was to check the updatehistory table.

 

I have the latest March 2018 CU Fixpack 24 and March 2018 Cumulative updates installed already...

0 Kudos
Reply