bhickok2
Apprentice

Registering a new service broker

Jump to solution

I have been attempting to register the worklist service instance. I copied the dll file to the k2 service and attempted to register the dll in GAC. It is still not showing on the drop-down to register the service.
I was following this article: https://help.k2.com/onlinehelp/k2five/devref/5.2/default.htm#extend/smo/registerdeploy.htm

I used powershell to register the dll via this article: https://www.andrewcbancroft.com/2015/12/16/using-powershell-to-install-a-dll-into-the-gac/
after noticing this issue from this article: https://help.k2.com/support-services/kbt143309

 

Anyone else have experience with this issue and know how to resolve this? Any help is appreciated. Thank you!

Ben

0 Kudos
Reply
9 Replies
Not applicable

Re: Registering a new service broker

Jump to solution
Hi Ben

 

Can you perhaps try the following and see if this resolves your issue:
Download and install the ODAC component.
http://www.oracle.com/technetwork/database/windows/downloads/index-090165.html

 

Restart K2Service after installing the ODAC component. Also make sure to check if Oracle.DataAccess is installed in C:Windowsassembly.

 

-Sello

 
0 Kudos
Reply
bhickok2
Apprentice

Re: Registering a new service broker

Jump to solution

That did not work. Instead it caused a bunch of errors on my server. Now I get this error everytime I attempt to launch the smartobject tester:

6940i27730E85E6CB6063.png

0 Kudos
Reply
boringNerd1
Apprentice

Re: Registering a new service broker

Jump to solution

Go to C:WindowsMicrosoft.NETFramework64v2.0.50727config, open machine.config with a notepad.


 


Right on the first line, you should see the xml encoding. What is it showing? The correct encoding should be UTF-8:


 


<?xml version="1.0" encoding="UTF-8"?>


 


I have seen similar errors when the encoding is set to UTF-16. If you have UTF-16 as the encoding, change it to UTF-8, end your SMO Tester using Windows Task Manager, then reopen your SMO Tester.

Reply
bhickok2
Apprentice

Re: Registering a new service broker

Jump to solution

Perfect, that fixed that issue. It seems though that I still cannot register a new service type. It is not showing in the dropdown. Any other thoughts?

0 Kudos
Reply
khanh1
Apprentice

Re: Registering a new service broker

Jump to solution

Hi,


 


As a test, could you restart the K2 Blackpearl service and check it again?

0 Kudos
Reply
bhickok2
Apprentice

Re: Registering a new service broker

Jump to solution

Yep, tried that again but nothing has changed. 

0 Kudos
Reply
khanh1
Apprentice

Re: Registering a new service broker

Jump to solution
Hi,

 

I would double-check if the DLL is in %PROGRAMFILES%K2ServiceBroker directory. I believe a restart of K2 service is needed for the K2 to recognize it.

 


 

Alternatively, you can try to register the Service Broker DLL file with the BrokerManagement.exe tool (%PROGRAMFILES%K2ServiceBrokerBrokerManagement.exe)

1. Launch BrokerManagement.exe tool and select Configure Services option.
2. Right-click Service to register 'Register New Service Type'.

 
0 Kudos
Reply
bhickok2
Apprentice

Re: Registering a new service broker

Jump to solution

After logging a ticket with support I found out that if you copy the .dll file into the service broker for some reason it is blocked. In order to unblock the file you have to right click on it, choose properties, check the unblock check box, apply and save, then restart the service. After that everything works fine.

Thanks for all the help!

0 Kudos
Reply
khanh1
Apprentice

Re: Registering a new service broker

Jump to solution

Hi,


 


I have also seen this happen a couple times if the DLL is blocked by the server. Could you also check on that?


-Right click the DLL file and select Properties. Check for the unblock button and click it.


Alternatively, you can unblock DLL from GAC assembly with Unblock-File cmdlet

0 Kudos
Reply