JulieBird
Apprentice

Performing 'Save As' for views do not show up in the form view selector

Jump to solution

Hi,

 

We have recently upgraded to K2 five latest version and I have just realised that when in K2 Designer and I do a 'save as' copy of a view then it does not appear in the K2 Smartform 'View Selector'.

 

Our base data is from a SharePoint list.


The new view shows in designer but I can't select it and drag it onto a K smartform as I could before... only the 3 default views that are created by default are available to pick from OR views that are created new from scratch.

 

The save as function we use a lot because we will build the format and layout in the New Item view and include all rules and functionality then do a 'save as' copy of this for the edit view and just change the 'Save button to do an update rather than a create new item.... this saves hours of time as many of our forms have 30 or 40 controls.


Is this a bug or can we no longer use the Save As functionality for K2 views?

 

Thanks, Julie

 

0 Kudos
3 Replies
emilyc1
Apprentice

Re: Performing 'Save As' for views do not show up in the form view selector

Jump to solution

Hi JulieBird,


 


Can you please confirm which K2 Five version this is?  Are you on 5.3? If so, have you applied any FixPacks to this environment? 


 


Once we have confirmed the exact version, I will go ahead and test on my end and report back to you.

Thanks!


Emily

0 Kudos
Widson
Apprentice

Re: Performing 'Save As' for views do not show up in the form view selector

Jump to solution

Hi  @JulieBird;


 


Please provide us with more content,screenshot perhaps---as we're not experiencing the same issue trying to repo...You can also consider logging a support ticket for the issue to be solved accordingly.


 


Cheers;


Widson.

0 Kudos
JulieBird
Apprentice

Re: Performing 'Save As' for views do not show up in the form view selector

Jump to solution

Hi Widson,

 

Thanks for the reply.

 

I have just gone to do some sample screenshots and I can now see the 'saved as' views in my view selector!  I tried it several times yesterday and even cleared my cache but they just weren't there, but now they are so I'll have to put this down to a glitch.

 

Very relieved to find the functionality is still there :-)

 

Thansk again for your prompt response.