AAschenbrener
Apprentice

Navigate to URL with Environment Variable

We setup an Environment Variable with a URL and I'm trying to do an On Image Click Navigate to this URL.  Which works - however the Open In (New Window) is not working.

 

It opens in the same tab.

I have other Navigate to Form / Hyperlink Navigates and those all open in New Tabs.

 

Anybody else having problem with a Environment Variable opening up in a new tab?


navigatetourlnotworking_3770.png
0 Kudos
Reply
4 Replies
khanh1
Apprentice

Re: Navigate to URL with Environment Variable

Hi  AAschenbrener,


 


I built a quick form to test the scenario but didn't run into any issues, see video link, The environment has K2 Five (5.2) May 2019 CU Fixpack 20. Which K2 version do you have on the environment? Do you have any plans to install the latest K2 Five FP? Also, does it work with Chrome or Firefox?


------------------


-Create an environment variable (field type = Miscellaneous)


-Default value is https://google.com


-Add a button click event with 'navigate to url' action (New Windows or Tab).


 

0 Kudos
Reply
AAschenbrener
Apprentice

Re: Navigate to URL with Environment Variable

On 5.2 - latest FP

Using an Image
-- Action Rule   
When Image is clicked
Transfer to URL
--  Environment Label to SharePoint URL
-- Open In -  New Window (Tab)

Opens in the same tab. 

0 Kudos
Reply
khanh1
Apprentice

Re: Navigate to URL with Environment Variable

Hi AAschenbrener,


 


Out of curiosity, can you test without using the Transfer Data action? 


8422iA28020F10FB75F8F.png

0 Kudos
Reply
AAschenbrener
Apprentice

Re: Navigate to URL with Environment Variable

I'm using the Navigate to URL rule (not transfer - sorry wrong wording)

0 Kudos
Reply