Sharpharp1
Apprentice

IS NULL not in Workflow Function

Hi,

 

Got a Workflow where filtering on a Table and I want to show all records with an empty column A.

Using the Tester tool you can do "Name IS NULL" and you get all Name records which are empty, but there is no IS NULL when done in K2 5.3 Designer Workflow

 

I tried Filter Name = Empty String (from the Text expression section) but the results are empty

What do i do?

0 Kudos
Reply
6 Replies
boringNerd1
Apprentice

Re: IS NULL not in Workflow Function

 


 


Have you tried just leaving the value in the filter condition as empty?  As in don't fill in anything.


8156i042DF91582602137.png


 

0 Kudos
Reply
Sharpharp1
Apprentice

Re: IS NULL not in Workflow Function

Hi bordingNerd,

 

Tried everything and the kitchen sink in that value box.

  • Leaving blank does not work
  • Using Empty String from Text functions does not work
  • Using an Empty Variable does not work
  • Adding the Empty String to the Variable does not work

The tester tool ISNULL works perfectly, without this in the Workflow i cannot achieve a simple thing like simply empty records.

 

Any other ideas or workarounds?

 

0 Kudos
Reply
ElvisJacob
Apprentice

Re: IS NULL not in Workflow Function

Hi Sharpharp 1


 


The feature request has been logged 


You can vote for it on the following link below:


https://ideas.k2.com/ideas/APIT-I-769


 


Regards


Elvis

0 Kudos
Reply
Sharpharp1
Apprentice

Re: IS NULL not in Workflow Function

Hi Elvis,

 

Feature request? So there is no workaround at all for this?

 

 

0 Kudos
Reply
ElvisJacob
Apprentice

Re: IS NULL not in Workflow Function

Hi Sharpharp1


 


This issue seems to be a bug, see the article below for workaround:


https://community.k2.com/t5/K2-Appit-Articles/In-the-Item-Ref-if-you-pass-the-quot-empty-Blank-quot-...


 


Regards


Elvis

0 Kudos
Reply
Sharpharp1
Apprentice

Re: IS NULL not in Workflow Function

Hi Elvis,
That links goes to "Previous Products - K2Appit" suggesting this is a very old bug, yet it says it would be a priority fix.

Hasn't this been fixed since then?
If not, when is the ETA for this?
0 Kudos
Reply