madhu_hari
Novice

Format Number - Region Selected Issue

Hi,

 

I am using in built Format Number function to format a number which is a currency. So in the format number function firsr parameter is my number and second parameter is "C" which stands for currency. While formatting, it is formatting into Pound symbol instead of $. 

 

If I open the styles option, by default use settings will show United Kingdom. I am not sure where this setting is pulled as my computer language and zone is set for en-AUS and Brisbane respectively. 

 

Can anyone help me out here?

 

Regards,

Madhu

0 Kudos
Reply
4 Replies
boringNerd1
Novice

Re: Format Number - Region Selected Issue

Hi,


 


Do you know what is the region and locale of the server hosting your K2 runtime?


 


Try opening your form on Chrome, press F12 to open the dev tools, go to Console and run the following command:


 


SourceCode.Forms.Settings.Culture


 


What do you get when you run that command?


 

0 Kudos
Reply
madhu_hari
Novice

Re: Format Number - Region Selected Issue

@boringNerd 

 

Hi,

 

Sorry that I missed to reply back. When I executed the command SourceCode.Forms.Settings.Culture in consolde, I am getting the answer as en-GB. I guess the form region is wrongly configured as en-GB. How to change that?

 

Regards,

Madhu

0 Kudos
Reply
boringNerd1
Novice

Re: Format Number - Region Selected Issue

Go to [Program Files]\K2\K2 smartforms Runtime, edit web.config with a text editor and look for this line:

<globalization culture="auto" uiCulture="auto" />

 

Change the culture to what you want. By default the values should be “auto”, which means SmartForms will use the culture of your browser. But you can change this if you want ALL users to use one specific culture by default. Again, modifying that line will change the the default culture for ALL forms and ALL users. If you have specific needs, you can still change the culture of controls in your forms.

0 Kudos
Reply
madhu_hari
Novice

Re: Format Number - Region Selected Issue

Thanks alot @boringNerd for the reply. 

is there any way we can change the culture of my browser than changing it in k2 server? I tried to change the language settings in Chrome but it still displays en-GB.

 

Regards,

Madhu

0 Kudos
Reply