Akuner
Scholar

Different date format displayed on user's end

Jump to solution

Hi There

 

I have a situation where date is formatted in a mm-dd-yyyy format rather than dd-mm-yyyy.

This is only happening to 1 user in particular. I have checked date time format on the computer it seems to be on dd-mm-yyyy.

Can anyone please advise me on how to resolve this issue?

 

Thanks

Labels: (2)
0 Kudos
Reply
3 Replies
boringnerd
Nintex K2 Expert
Nintex K2 Expert

Re: different date format displayed on user's end

Jump to solution

Have you tried setting a custom date format on whatever control you are using to display the date? That way all users should see the same date format regardless of what date settings they have on their machine.

0 Kudos
Reply
AMolyneux
Nintex K2 Expert
Nintex K2 Expert

Re: Different date format displayed on user's end

Jump to solution

By default, a Calendar controls Date and Time format is set to the “Type” of “Short Date” and the “Language/Region” to “User settings”. This means that the calendar control will utilise the user’s browser culture to display, but you can override this by selecting the “Use” option and then specifying a culture to use e.g. English (United Kingdom).If you want to use a differ formatting type than available via the “Type” drop-down, you can then specify your own custom format.

 

Capture.PNG

0 Kudos
Reply
KimberlyL
Nintex Employee
Nintex Employee

Re: Different date format displayed on user's end

Jump to solution

Hi Akuner,

The date format is also dependent on the language settings on the user’s browser as well. If multiple languages are available, a browser uses the language with the highest priority to decide the format in which the date is displayed.

Chrome and Firefox display the date in MM/DD/YYYY. You can change the date format in Chrome to display as DD/MM/YYYY using these steps:

  1. Click on the "three dots" icon on the top right in Chrome and then click on Settings. 
  2. Click on Advanced > Languages. 
  3. Expand the Languages section.
  4. Add e.g. ‘English (United Kingdom)’ and move it to the top by clicking the "three dots" icon on the right.
  5. Close the Settings tab.
  6. Restart the browser and load your form.
0 Kudos
Reply