Solved

Open Workbook Error 13: Unable to cast COM object of type 'Microsoft.Office.Interop.Excel.Applicati'

  • 27 June 2020
  • 6 replies
  • 1127 views

Hi All, 

 

I am new to Nintex RPA and trying to create one bot which starts by openning a workbook. Once I try to run the script, the action "Open Workbook" give me the following error: "Error 13: Unable to cast COM object of type 'Microsoft.Office.Interop.Excel.ApplicationClass' to interface type 'Microsoft.Office.Interop.Excel._Application'. This operation failed because the QueryInterface call on the COM component for the interface with ID.....failed due to the following error: Element not found. (Exception from HRESULT: 0x8002802B (TYPE_E_ELEMENTNOTFOUND))." (see attachment).

 

I tried with different workbooks and only with this action. I am using local version of Excel of O365.

 

I appreciate in advance for any help.

icon

Best answer by john_armstrong 2 July 2020, 16:47

View original

6 replies

Userlevel 4
Badge +11

From some online search on the error, this looks to be an issue at MS Excel level (Trusted publisher settings, previous versions installed).  Here are some resources:


https://support.microsoft.com/en-us/office/add-remove-or-view-a-trusted-publisher-87b3d5a3-b68c-4023-87c4-7cc78a44d7ed


https://docs.microsoft.com/en-us/previous-versions/system-center/configuration-manager-2007/bb633148(v=technet.10)?redirectedfrom=MSDN


https://docs.microsoft.com/en-us/archive/blogs/dau-blog/how-to-solve-unable-to-cast-com-object-of-type-microsoft-office-interop-excel-applicationclass-to-interface-type-microsoft-office-interop-excel-_application


 

Userlevel 3
Badge +7

Hi @AR_Nintex 


 


This article may be useful for you:


https://help.nintex.com/en-US/rpa/Troubleshooting/FixExcelFileImport.htm


 


The issue outlined is not an exact match, but the solution should be the same.


 


Let us know how it goes.


-John

Hi Sasan, 


 


Thank you for your help. I tried but none of them could help me. 

Hi John, 


 


Tried this solution and it worked. Thanks a lot for your kind help. 


 


Regards,

Userlevel 4
Badge +11

One more option from a another customer that ran into this. 


"I went ahead and repaired Office from Programs and Features, after that ran it uninstalled office on its own due to an error with two versions of access installed in the machine. Once that cleared I did a fresh install from the Microsoft website verified the registry to assure there was only one version of access then tested the product and that finally cleared that error."

It was a good and quick help. My Excel is now running under Visual Basic 2019 and Excel 16.0

Reply