Downloading Roles


I'm trying to delete created roles which are no longer in use. So I need a report that would show the  the list of roles not associated to any process. Anyone familiar with this? I tried Reports > Process Activities By Role and Responsibility, it only gives me published process, If I ticked box for unpublished I'm getting an error.

I needed to delete roles that are not associated to any flows.


Appreciate your inputs!



Best answer by MattHSpears 13 June 2022, 18:53

View original

8 replies

Userlevel 3
Badge +6

Hey @Joyce2021 - you can navigate to Admin -> Roles -> click on the Excel logo in the upper right hand corner. This document will show you which processes each of your roles are linked to.

Hi Matt, 

I was able to download roles associated to published process under Admin > Roles. But I need the report to show if a role is not associated to a process at all, either published or unpublished. The one with zero data under Participates could be associated to an unpublished process. 


I need to delete roles that are not in use. Hope I'm making sense.

Userlevel 3
Badge +6

Hey @Joyce2021 - you will want to run the report you mentioned in your first post (Process Activities by Role and Responsibility). I was just able to run this report with the box checked to "show roles from unpublished changes" and did not get any error message. Please try this again and see if you can replicate the error message. Thanks.

tried, getting this errror: 

Error creating report document (Report = '10'; Format = 'HTML5').

500 - The request timed out.

Userlevel 3
Badge +6

Thanks for confirming that @Joyce2021. At this point, the best thing to do is send that screenshot and description over to our support team at They will be able to troubleshoot this for you. I'm sorry for this inconvenience. 

thank you 🙂

Userlevel 3
Badge +8

Just FYI, I also cannot run the Activities by Role and Responsibility report.

I've raised it as a support case with Nintex; hopefully they get it sorted soon as it can be a useful report (I use it to identify orphaned activities  ie with the Unassigned swimlane).


I did raise a ticket quoting their advice :  "Apologies for the delayed response, this time out error you get when running the report our team has classified it as a current defect that is being worked on by our Dev team. As a workaround to be able to run the report please filter to a specific group to prevent the timeout issues. We have tested this out and the report should work when filtering."


Filtering worked for a bit but I'm getting timeout error again, sent a ticket and was advised they will look into it. Hope this helps.