Error in workflow due to incorrect permissions? Please help

  • 5 October 2021
  • 1 reply

I have a workflow running where request is submitted via one list and then the workflow is creating multiple items to another list that will then worked on by different users. 

I need the initial request list to be accessible to everyone in the bank (no restrictions), so for permissions on the list, i chose everyone and gave them contribute access. I had it tested with the user and although user is able to access the page and create a new request, my workflow is throwing the error below: 

" the workflow couldn't update the item, possibly because one or more columns for the item require different type of information"  outcome: access denied.


When i create the request (as an admin) or users who have edit permission to all sharepoint pages created the request- the workflow is working. 

Seems like there is an issue where sharepoint is blocking the creation of the item in another list from the original list if the user on the original list has access to that list only? Is there a way to fix this? 

I only need users to be able to raise the original request and not see the rest of the sharepoint, and then the items created as a result of the request will be reviewed by specific group members.

1 reply


Have you tried configuring the action to run as the workflow owner?  It's on the Common tab of the action.

That will allow the action to act with your permissions, not the person who initiated the workflow.