Workflow suddenly start generating intermittent errors on save/publish.

Badge +3

The only reference I saw to something like this was from 2016 and had no actual resolution (just a nebulous, "your workflow is too big" conversation). Which I might believe if a) we didn't have larger ones, and b) trying to restore back to the original, smaller workflow in development still causes the issue.

Recently we finished a list/form/workflow update and were asked to replicate the new piece to another, related list. After spending a good chunk of a day creating the couple new columns, updating the form and then adding the actions to the workflow in development we did some tests. Everything looked good other than I hadn't updated the text in the emails from the approval tasks. 

So the following morning I began to add those same parts to production. After getting part of the way through I saved and kept going, on the next save attempt I received:

Oops! Something went wrong.
If the problem persists, contact your support team with the following information:
ButtonPanel - handleXamlBuildError : SyntaxError: Unexpected token 'P', "Publishing"... is not valid JSON

This happens intermittently. And when going back to development to try some things I immediately started seeing the issue there too. Basically Wednesday I was about 95% done in dev, Thursday start adding same actions to production and don't even get as far and the error starts up. Then see it on dev too. 

We've had a ticket open with Nintex for days and they're looking into it. But maybe someone has recently seen this issue in the community? As I mentioned, even trying to restore things back to how we started in the development space, with less actions, to see what would happen resulted in the same error. Thanks!


Best answer by JakeHarvey 30 August 2022, 21:24

View original

17 replies

@JakeHarvey I am running into the same issue. Any update from Nintex as to the cause or resolution?

Badge +3

Hi @nicole_vesser, not exactly. I had a call with a support person who thought it was definitely the size of the workflow. If not for the actual action list, potentially the complexity of the actions/logic.

So per their advice I went about splitting it in two. Went from 165 actions listed, to a step 1, with 50, and a step 2, with 127 (the numbers differ a bit since some extra pieces needed to be added so step 1 would wait for step 2 to finish, etc.). 

Sadly we're still getting the error intermittently when saving. 

Out of curiosity, is this new for your environment too? How large is the workflow where you're seeing the issue?


I just started seeing the same issue today.  We have two almost identical workflows, same action count and almost all the same settings for each action, and I'm getting this error on one workflow when I publish, but not the other.

We're seeing this issue across multiple tenants. Has there been anything from Nintex or has anyone had luck with support?

Badge +3

We have been experiencing the same issue since Monday Aug 22nd. Everything was fine last week.

Half the times a workflow will save; half the times it won't. And this is without making any changes to our currently published workflow.


We wrote support, and got the standard answer that the size is too big. I just opened up a larger workflow that's a few kb's bigger in size, and that worked fine saving the first time.


So if this issue were related to size, I would think it should be failing 100% of the time.


Nintex really need to seriously start looking into this as it's an obvious issue with everyone here from around the world reporting the problem.

Badge +3

Thanks for chiming in everybody. 

No new, news on my end from Nintex. However, I did have a call with our consultant who helped set these up and after not having any issues on his end we used the browser inspect feature to see what was happening behind the scenes (something I should have thought of). 

In any event, there isn't a huge difference between when it's successful vs. when it fails other than the web address for saving responds with a 503 error. I'm going to report this to Nintex in our support ticket. 

I imagine not everyone is as technical as me, but out of curiosity, how large are your workflows? 

I'll report back with any updates. 

@JakeHarvey - Thanks for sharing your experience after splitting the WF into two. That was the directive Nintex Support gave to us also, so that helps to know that isn't the magic bullet in this case. Our WFs are similar in action count to yours: between 150-200. We are currently experiencing several different errors (when opening the WF designer, saving the WF, and exporting the WF) intermittently across both the Dev and Prod tenancies. And, yes - these are recent issues. We started noticing these issues on the morning of 8/18/22. In fact, we published a minor update to the WF on the afternoon of 8/17/22 without any issues. 


Do you mind sharing which Region your tenant is in? Ours is West US. 

Badge +3

3.45mb is the actual size when exported and extracted.


For anyone who doesn't know:

1) export the workflow

2) change the extension to ".zip"

3) extract the zip file


Hi There,
It might be good idea to share the exported file for your workflow to support that way, they can troubleshoot your issue.
Had anyone managed to share their workflow to support yet ? 


We will be providing one of our problematic workflows to support for their investigation as we are also only seeing it intermittently and not on all workflows (we have larger workflows which seem to be fine).


Any updates we get I'll try to share here

Badge +3

I've emailed them as well with a workflow that is failing intermittently. 


I've also provided their support team a link to this thread so hopefully they'll be good enough to check this out and combine their efforts instead of working independently.

I have four workflows I'm seeing this on right now, though those are the only ones I'm working on right now.  But they are all around 84 actions and 139k exported.  So not large at all.

Badge +3

We have supplied multiple workflows. 😃 

Badge +3
Thanks again everyone, latest response from our support person was that "We have recently had other customers report this error," and they're looking into it. Hopefully they sort out the cause fast and can get us all back to editing.
Badge +3

I just sent Nintex another email with a screen video recording of the error occurring, along with the HAR file from the recording.

Badge +3

Hi everyone, 

Thanks again for reporting. I got a notice the other day from the tech support person helping us that on Friday they had sorted out the 503 error that came later. And today I received word that the dev team had also put in another fix shortly after. They thought the second fix might help with the other, original error. 

So far I've been saving and publishing the original workflow, along with others to test, without issue so far this week. I did get one error while publishing from a tab that had been open for a while, but a reload and re-try worked. 

I now plan to go back to what I was working on that started this whole thing and try to finish it. I'm guessing these two fixes behind the scenes might halve solved it. Chime in with your successes/failures and hopefully I can mark this as closed. 

Badge +3

Ditto. It's working for us now too. I closed off our Nintex Support case last night to let them know we haven't experienced any further errors this entire week.