Solved

Workflow not available to api?

  • 22 March 2018
  • 3 replies
  • 2 views

I have created a new workflow and published it.  I have also created a new instance of it through k2 management just to make sure it's working.  I would like to start the workflow through the api but I'm having difficulties.  FIrst off I tried to get the id of the workflow by calling the "Get Workflows" through the swagger.  This returned a list of workflows on the server, but the one I was looking for was not among them.  I then figured out based off the ones that were returned that the id is the last section of the url when viewing a workflow in the K2 Management studio.  From that I was able to get the id of the workflow in question.

 

When I try to execute either the "Get Workflow" or "Start Workflow" passing in the id of the workflow I wasnt I get an error saying...

"Message": "The identified workflow was not found."

 

Is there something special I need to do in order to get my workflow to interact with the api?

icon

Best answer by Ryan_Crawford 23 March 2018, 13:50

View original

3 replies

Hi,
find a link below that might help your current situation, seeing that your error appears when you execute either the "Get Workflow" or "Start Workflow".

https://help.k2.com/kb001941

K2 will not accept any liability for any issues arising from actions taking in respect of the information provided by any forum member.

Hi,


 


I am assuming you are using the new workflow REST API that comes with K2 Five. Once you have deployed the workflow, it should get listed when you try to use 'Get Workflows' to fetch all the list of workfllow.


 


Have you tried playing around with the type when you call the 'Get Workflows' ?

It looks like it was a permissions issue.  There are two accounts with the same name in our environment, one is AD and one is a K2 account.  Apparently we needed both in there.  I got confused as it appeared that the permission account was in there already judging by name, but it also needed to add the k2 account.  After adding permissions for both accounts I can interact with it now.  Thanks for the quick replies!

Reply