Solved

"Disable the Form" Rule action not disabling the form

  • 9 January 2019
  • 5 replies
  • 1 view

I'm building a registration form with some checks while the form initializes, so I had a semi elaborate bunch of "if conditions" "else", but everything was executing as expected, except the disable the form. So I disabled the whole content of the rule and just threw in a "Disable the form" when the form is initializing, and not even that works.

Please refer to the Rule.png for the rule composition, and refer to the Form_rendered.png for the form after opening.
The form should disable itself right away, but it does not, it stays enabled. Could anyone give me an idea of why it's not disabling? Thank you



icon

Best answer by khanh1 9 January 2019, 23:42

View original

5 replies

Are you using form states?  Could your disable rule be in the base state and it is susequently overridden in another state?

(With the lithum color screen it is actually hard for me to tell from the screen shot whether the fields are disabled).

I am not using form states. I should have input some text in the fields to show they were enabled. 

 

 

 

This screenshot shows that it is enabled.
While troubleshooting I figured out what causes the problem, but still no solution.
The problem is caused when I use Tabs on the form. If the form contains a tab (instead of no tabs and all in the same screen) it seems to cause this problem. Even with newly created forms, I have tested this a few times (witht the screenshot being from one of the tests)

Hi,


 


Perhaps,  you can use Set the Form's Properties action to disable the form.


1. Add Set the Form's properties action.



2. Set Enabled checkbox to No.



 


 

Thank you!
This seems to have worked.
It's odd that the main "Disable the form" action does not work.

Fix Pack 17 for 5.2 was just released on 1/22/19 and I see it does include a fix for the disable form rule problem.  It was indeed a bug.

https://help.k2.com/kb002941

 

Reply