Missing Reference at SmartObjectField: error: Item has already been added.

  • 29 October 2018
  • 4 replies

Badge +8

Workflow error, I cannot deploy.


Missing Reference at SmartObjectField: error: Item has already been added. Key in dictionary: 'Status' key added: 'Status'. Stack Location: K2Process 'SRTS'  Stack end.


I keep on changing my SMO, I also did refresh my instance to SQL but still no luck.


for your guidance.






4 replies

Badge +9

Hi Dabuskol,


Does your SmartObject contain the Status Field?

Have you tried to rerun through your wizard and make sure that there are no errors?



Badge +8


There were no errors.

My Solution and it works but strange.


I removed the stored procedure inside the smartobject and replaced it with a new table SMO to update the status and it worked.

No Idea for now the future effect.

Haven't heard from K2 Support as well.



Badge +16



I have seen something similar to this in the past. Is the workflow setting up similar to the below scenario?


-Workflow has an item reference step that is based on a SmartObject (SQL stored procedure).

-SmartObject definition is updated to use the SQL table instead of the SQL procedure.

-The above item reference from the workflow is now out-of-synced, it's still preferring to the SQL procedure.

-To fix it, the item reference step will have to re-create.



Badge +4

Hello Khan,


I currently have this same issue.

I created a table on SQL server and current use it as an Item reference on my flow.

I have recreated my SmartObject from the SQL server service table severally, and even recreted my SQL Server table and still have same issue.

I have done all recommended above, and is still same. What can anyone recommend for Me, as this is urgent.


Will like to know if there is a Fix for this, as I currently use K2 5.1