Skip to main content


 

Symptoms


Dear Support,

We have a workflow created in smart forms designer. We could able to modify and deploy the latest version till last working day. However, from today itself when I am trying to edit and deploy the latest version, it showing error "item with the same key has already been added".
 

Diagnoses


This issue disappears on it's own after doing a chein check out and for other reasons mentioned in the resolution
 

Resolution


Resolution:
"
The issue dissappeared on it's own.
possible causes:
1. when cancelling the checkouts or checking in the form, we were able to deploy without this error: we were not able to reproduce the behaviorerror
2. Issue appears to have occurred due to a corrupted installation . Validated 105 and 466 install , restarted K2Service (After having the re-register it) . Suggestion to do repair of 466 then 105
3. Error trying to deploy a K2 process that tries to transfer data from the smartform to "Activity" level datafields. It works with Process Level Datafields. fixed when when we cancelled the checkouts or checked in the form, we were able to deploy without this error.
4. in case of using SF client events have you checked if all the forms have been checked in?
5. -checked the SourceCode.Form.Runtime.Error log on one of the K2 servers and I noticed that there were some references to a theme . gone through the Smartforms Runtime directory looking for any files that had changed recently, and the only one to have been modified was the folder for the theme - although no files inside it had been modified.
- checked in the K2.Form.Theme table, and there were two entries for the theme. After copying the bottom-most entry in order to be able to restore it, removed it from the table. re-tested the forms, and they appear to be working now.
6. after re-running and resetting all configurations in SmartForms Integration and SmartForms Client event wizards.
7. there is a hotfix for this issue in 4.6.7 If the client does a fresh re-install of 4.6.7 the issue will come back, and they will need to re-run the hotfix script .
8. Another option would be to upgrade to 4.6.8 - as the issue was addressed and fixed for 4.6.8.
9. Have you deleted any SmartObjects that was in use by this workflow? If you have please update the design template and give it another try.
10 If possible download older versions of the workflow and double check that there are no SMO's attached to this workflow.
If you happen to find one check with the current version if that SMo is being used.
11. Reverting the form to an earlier version eliminated the issue. The URL pasted below depicts the process that took care of the issue that the edits caused. http://help.k2.com/kb001311
"




 
Be the first to reply!

Reply