Skip to main content
Nintex Community Menu Bar

Unable to register a SharePoint 2013 instance

  • March 3, 2015
  • 0 replies
  • 8 views

Forum|alt.badge.img+10


 

Symptoms


When trying to add a service instance for Sharepoint 2013 you receive the error:

SmartObject Server Exception: SmartObject Server Exception: resourceID
Parameter name: Value not provided

Source: SourceCode.SmartObjects.Services.Management

Inner Exception : SmartObject Server Exception : resourceID Parameter name: Value not provided.
Source : SourceCode.SmartObjects.Services.Management.
 

Diagnoses


This error occurs when trying to register the K2 for SharePoint 2013 service instance through the SmartObject service tester.
 

Resolution

In the following documentation, we note that manually adding the service instance is no longer supported: http://help.k2.com/onlinehelp/K2ForSharePoint/UserGuide/1.0.1/default.htm_Build_Integrate/The_SharePoint_2013_Service_Brokers/SharePoint_2013_Broker.htm

Instead, we create Service Instances when you register the app against a site collection. This is done using the instructions here:

http://help.k2.com/onlinehelp/K2ForSharePoint/ICG/1.0.1/default.htm_Install_Topics/OnPrem/On-Premises_Installation.htm?TocPath=_____4 under the "Add the K2 App to the SharePoint Site" header, sections "Activating K2 for a SharePoint Site" and "K2 for SharePoint Registration Wizard"