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Symptoms


It's possible to connect to the mobile application but when we try to display the list of the forms, we get the following error message:

Response code : Unknown Response
Hostname srv-k2-dev not verified.

Note: In this example, hostname is the internal hostname not external.
External URL is : k2-dev.xxx-systems.fr
 

Diagnoses




Execute the following query on the K2 database and check if the urls (started by http) are the correct one : external url, not internal.

USE HostServer --Change here if necessary the K2 Database.
GO

select * from mConfiguration] order by 3


As you don't have any issue in production, we check the K2API application and found that the provider for Production was only NTLM, and the DEV (with issue) was Negociate and NTLM. Then we removed the Negociate without success.

 

Resolution

Blackpearl setup manager: do a "Modify" and change only all the bindings: srv-k2-dev to k2-dev.xxx-systems.fr (The external address)
SmartForm setup manager: do a "Modify" and change only all the bindings: srv-k2-dev to k2-dev.xxx-systems.fr (The external address)







This issue appeared apparently because we start by the "SmartForm setup manager" and after "Blackpearl setup manager" in the resolution steps.

ISSUE 2:
We we try to connect to the K2 Mobile Application we have the following error:
"
Network Requests - Raw Error Response
Response message:An Error has occurred.

Network Requests - Application Forms Download Failed"
Internal Server Error
An error has occurred
Wifi Connection Active
"

or

"
Erreur de serveur

Une exception de type 'System.Web.httpUnhandlededException' a ?t? lev?ee".
Le contr?le d'extendeur '0000000000-00000-0000-0000-0000000_63d5.....' n'est pas un contro?le d'exendeur inscrit' Les contr?les d'extendeur doivent ?tre inscrits via RegisterExtenderControl() avant d'appeler RegisterScriptDescriptors().
Nom du param?tre: extendeurControl
"

DIAGNOSIS 2:

The issue is apparently because we start by the "SmartForm setup manager" and after "Blackpearl setup manager".

RESOLUTION 2:
Re-start the "SmartForm setup manager" and double check bindings.






You still have an issue but after some test, we found that it's linked to the MultiLanguage control: when we test with the view only, we don't have issue.



You have 2 days to accept or reject this resolution. If you feel the issue is not resolved, please reject this resolution.
Otherwise, please take the opportunity to submit feedback, using the link included in this message.

Thanks, and regards
Olivier Chatagnon




 
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