Skip to main content
Nintex Community Menu Bar

Unable to load the workspace - Membership could not be verified / web.config error

  • September 18, 2007
  • 7 replies
  • 34 views

Forum|alt.badge.img+2

Hi K2 guys,


My K2 server is now running, but I cannot reach my workspace, and I get the following error :



Error:
Membership could not be verified: Only LDAP connection strings are supported against Active Directory and ADAM. (C:Program FilesK2 blackpearlWorkSpaceSiteweb.config line 103)



This is my web.config, with the line 103 in bold :



<connectionStrings>
<remove name="LocalSqlServer"/>
<add name="LocalSqlServer" connectionString="Data Source=[SQLSERVER];Database=Workspace_Beta2;Integrated Security=SSPI"/>
<add name="ADConnectionString" connectionString="[COMLDAP]"/>  </connectionStrings>
<membership defaultProvider="AspNetActiveDirectoryMembershipProvider" userIsOnlineTimeWindow="1600">
<!--<membership defaultProvider="MembershipProvider" userIsOnlineTimeWindow="1600">-->
<providers>
<clear/>
<add connectionStringName="ADConnectionString" connectionProtection="Secure" enablePasswordReset="false" enableSearchMethods="true" requiresQuestionAndAnswer="false" applicationName="/" description="Default AD connection" requiresUniqueEmail="false" clientSearchTimeout="30" serverSearchTimeout="30" attributeMapUsername="sAMAccountName" name="AspNetActiveDirectoryMembershipProvider" type="System.Web.Security.ActiveDirectoryMembershipProvider,System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
<add requiresQuestionAndAnswer="false" connectionStringName="LocalSqlServer" applicationName="/" enablePasswordReset="true" enablePasswordRetrieval="false" minRequiredPasswordLength="1" minRequiredNonalphanumericCharacters="0" name="MembershipProvider" type="System.Web.Security.SqlMembershipProvider"/>
</providers>
</membership>



 


Has someone already faced that issue ?


Thanks for your help,


Antoine 

7 replies

Forum|alt.badge.img+11
  • Nintex Employee
  • September 18, 2007

Hi Antoine,


I haven't seen the specific error before but similar ones...


Please have a look in the web.config file - Line 42 should define your 'ADConnectionString' - and verify that the connection string presented there is in the correct format.


My ADConnectionString look like this:


<add name="ADConnectionString" connectionString="LDAP://K2DEMO.LOCAL" />


Using some tool like Microsoft's 'adsvw.exe' (downloadable from their website), verify that you can successfully connect to your domain controller.


Regards,


Ockert


Forum|alt.badge.img+9
  • Nintex Partner
  • September 19, 2007

Antoine,


I encountered the exact issue during Beta 2.1.


After researching this type of connection string (the one Ockert refers to) online, I found a general (i.e. non-K2) article that stated the need to occasionally add the port# to the AD LDAP connection string.


The original LDAP connection string within the Workspace web.config was:


                                 <add name="ADConnectionString" connectionString="LDAP://somedomain.com"/>


 I modified it to add the port default AD port # 389:


                                 <add name="ADConnectionString" connectionString="LDAP://somedomain.com:389"/>


I think I did an IISRESET for good measure (although may not be necessary) and then I was up and running.  You'll want to confirm the AD Port # in your environment.


HTH.


Bob


Forum|alt.badge.img+2
  • Author
  • September 21, 2007

Ockert, Bob, thanks for your contributions !

I've managed to get another error message in my browser, which makes me think that my K2 installation looks like unfinished business :

 Error:
Please verify that all necessary scripts were run and review
the error logs

 Any opinion on that ?

 Thanks !
 


Forum|alt.badge.img+9
  • Nintex Partner
  • September 21, 2007
courtina,

I assume you got past your original question. What did you need to do to resolved the "Membership could not be verified" error?

As for your new question, please refer to post:

http://k2underground.com/forums/thread/18491.aspx

Forum|alt.badge.img+2
  • Author
  • September 24, 2007

icon-quote.gifBob:
courtina,

I assume you got past your original question. What did you need to do to resolved the "Membership could not be verified" error?

As for your new question, please refer to post:

http://k2underground.com/forums/thread/18491.aspx

Ok, here is what I used to get past my original error :

<add name="ADConnectionString" connectionString="LDAP://[DC.NetBiosName]:389/dc=[],dc=[],dc=[]" />

Sorry about the off-topic last question, I'll refer to the indicated post Tongue Tied

Thanks 

 Antoine
 


Forum|alt.badge.img+11
  • November 6, 2012
Thanks a lot this approach helped me in solving the same problem on k2 1370

Forum|alt.badge.img+11
  • November 6, 2012
i mean adding the port