Skip to main content


 

Symptoms


Unable to access K2 Workspace
 

Diagnoses


Upon installing K2 Blackpearl, you experience the following within the configuration analysis with further errors not allowing you to access workspace:

The error show is:

"An error has ocurred
Please contact your administrator
Error:
Initialization failed before PreInit: The specified directory service attribute or value does not exist (C:Program Files (x86)K2 blackpearlWorkspaceSiteweb.config line 113)
Possible causes
- using anonymous logon in IIS while Windows security is specified in Workspace configuration.
- current logged on user can not be verified against the Active Directory Membership provider.
- please review log files for more information.
"
 

Resolution

It could be the case that the NetBIOS name of the domain and the FQDN don’t match. Usually you should have “******” is the “short name” of the FQDN “*****.com”. But it could be the case that the correct named version is not displayed here.

To get around this you will have to change the “Web.config” file for the “Workspace” under “C:Program Files (x86)K2 blackpearlWorkspaceSite”. We changing the “ADConnectionString” key from:



To
 



 
Be the first to reply!

Reply