Skip to main content
Nintex Community Menu Bar

SmartObject based on a Workflow Service method : Invalid Archive Type

  • December 6, 2007
  • 5 replies
  • 27 views

Forum|alt.badge.img+8

I've created a SmartObject based on the Workflow Service ServiceObject method called "List Worklist Items". When I call it, I get an "Invalid Archive Type" error.


I've also tryed with "Load Worklist Item", providing a valid serial number when calling it, but I get the same error.


 


Any idea? I'm feeling desperate...

5 replies

Forum|alt.badge.img+10
  • Nintex Partner
  • December 6, 2007

can you provide some detail as to the environment, is K2 all on one box, what version of VS are you using etc.


Forum|alt.badge.img+8
  • Author
  • December 7, 2007

Yes Sir!


One MOSS front-end + Reporting Services + K2 Workspace server, one SQL server, one K2 server (worklfow, SmartObjects, etc.)


I'm using Visual Studio Professional Edition 2005


The error occurs when calling the SmartObject method, whether it is from an Infopath or an ASP.net form (thanks to SmartObject Viewer).


Forum|alt.badge.img+8
  • Author
  • December 12, 2007
Nothing new about this? I fear, if you never heard of it, this issue won't disappear with SP1.

Forum|alt.badge.img+8
  • Author
  • December 14, 2007

Thanks to an almighty K2 consultant, here is the solution:



  1. In the K2 Workspace, click on Management --> Management Console.
  2. Expand the root node (your server), then Smart Objects, then Services
  3. Click on Workflow Service, select the one you want to modify, and click on Modify in the toolbar
  4. Set the Workflow Server value to your server name concatenated with a colon and the workflow server port number (for instance "myserver:5353" if you changed the port number because of K2.net 2003 running on the same server)

By default, no port number is provided, and Blackpearl might then use the default 5252, this is why so few people seem to experience the same problem.


Forum|alt.badge.img+8
  • December 17, 2007

I was getting this error all over the place and was causing me significant pain.  I would only get this error on create method calls and I found out that changing the order of the values I was setting or changing the values I was setting themself would solve the problem.  Yes it makes no sense and stumped myself and K2 support.


My resolution, SP1 has resolved the problem...


J