Skip to main content
Nintex Community Menu Bar

SharePoint Trust Change has broken all K2 solutions in our production environment

  • August 26, 2016
  • 0 replies
  • 15 views

Forum|alt.badge.img+9


 

Symptoms


1) VALIDATIONThe remote server returned an error: (401) Unauthorized.Failed to initialize the Context: URL: http://SiteUsername: Error Details: Method: SharePointService.initializeContext x-ms-diagnostics : 3000006reason="Token contains invalid signature."category="invalid_client" SPRequestGuid : 5dc3649d-3d96-40db-641f-5cebab2428b3

-This was thrown when loading a form in SharePoint

2) The remote server returned an error: (401) Unauthorized.Failed to initialize the Context: URL: http://SiteUsername: Error Details: Method: SharePointService.initializeContext x-ms-diagnostics : 3000006reason="invalid audience uri."

- This was also thrown when loading a form in SharePoint.
 

Diagnoses



1) Unknown

2) Because the trust had been redone and an oAuth repair run and by extension the certs updatesall of the tokens were bunk as they were signed under the context of a now invalid certificate.

 

Resolution

1) We fixed that by creating a new site which of necessity runs the timer jobs in sp and then registering k2 to that site. Either the timer jobs or the fresh registration wizard run fixed this

2) Deleted all the oAuth tokens using the manage oAuth token form for the user and then opened an incog browser and reran the registration wizard to recreate the tokens which fixed the error