Skip to main content
Nintex Community Menu Bar

Server was unable to process request. An item with the same key has already been added.

  • August 5, 2015
  • 4 replies
  • 31 views

Forum|alt.badge.img+11

I am using SharePoint 2010. I havea workflow in Nintex 2010 that I am trying to modify. This workflow is not new. It was created in early July or the end of June. I tried to make a modification to the Set Item Permissions. I wanted give permissions to one more person with a different type of permissions than those in there. It is a simple change. However when I make that change, I get a yellow triangle over the action indicating something is wrong with it. Yet, no error displays when I hover over it. When I try to save the workflow, I get the error message:

 

Server was unable to process request. An item with the same has already been added.

 

What is the deal? This is getting on my nerves!!!

4 replies

Forum|alt.badge.img+17
  • Nintex Partner
  • August 6, 2015

What happens if you delete the action and add a new one (or two) with the setup you need? Does it publish?

 

Don't forget you can rollback a version if you want to undo.


Forum|alt.badge.img+11
  • Author
  • August 6, 2015

You are the bomb Andrew! Its a shame I have to delete it. What I did is create a new action without deleting the other one. It still worked without deleting the other one. I guess the other one was corrupted some how. Once I got the new action set up the way I wanted, I deleted the old one.


Forum|alt.badge.img+17
  • Nintex Partner
  • August 7, 2015

Glad that worked, I've done this in the past with similar situations.


Forum|alt.badge.img+11
  • Author
  • August 17, 2015

Its crazy you had to delete it. But as long as it works!