Skip to main content
Nintex Community Menu Bar

Resolution to error encountered when accessing workspace

  • September 7, 2007
  • 4 replies
  • 22 views

Forum|alt.badge.img+9
  • Nintex Partner

The other day I saw the below message when attempting to connect to Workspace:


Error:
Please verify that all necessary scripts were run and review the error logs


 



The issue was that the identity runing the Workspace app pool did not have the proper permissions to access the databases in SQL. 


 


Once this was resolved Workspace came up without issue.


 


 

4 replies

Forum|alt.badge.img+11
  • Nintex Employee
  • September 7, 2007

Thank you for the feedback Bob.


(I need to get my posting count up 🙂)


Forum|alt.badge.img+2
  • September 24, 2007

Hello Bob,

I have the same error :
Please verify that all necessary scripts were run and review the error logs

Can you give us more details about the SQL permissions required by the  Wkspc app pool identity to access the databases ?

Thanks in advance

Antoine
 


Forum|alt.badge.img+2
  • September 26, 2007

For the record, I figured out that the workspace had been installed after the server + conf manager, and were located on two different drives.

So I just uninstalled the whole package, then add VS'05 Pro + WWF extensions, and reinstalled K2 Server, Workspace, Conf Manager & Studio Designer

It is now running fine 


Forum|alt.badge.img+5
  • December 10, 2007

I had the same problem before, and it has been successfully solved!

Firstly, make sure that the application pool is running on the right account. Secondly, make sure to give this account "who runs the K2BP workspace" the right permission on the database.

Just to be sure, enable SQL Server auditing to log failure logins only. After that, check the event viewer for the recent SQL connections.