Symptoms
Error when activating a site collection from the App Catalog:
Diagnosis
On the environment where this occured, only new site collections, those which have not been activated, are getting this error.
Solution
-
- From the K2 Server, open the SmartObject Service Tester as the K2 service account.
-
- Expand the SmartObject Explorer and go to System > SharePoint 2013 Integration.
-
- Select the SharePoint Integration Helper Methods SmartObject and choose the Activate Site Collection method.
-
- Provide the Site Collection URL.
-
- When it returns Success, re-run the Activation