Skip to main content
Nintex Community Menu Bar

P&D Tool Deployment Error: Could not publish SmartObject Definition to server

  • April 2, 2015
  • 0 replies
  • 3 views

Forum|alt.badge.img+9


 

Symptoms

 


When using the Package and Deployment tool to deploy a SmartBox SmartObject the following error is thrown:

Could not publish SmartObject Definition to server: Service could not be extended. Service Guid 'xxxxxxx-xxxx-xxxx-xxxxxxxxxxxx'

 

 

Diagnoses

 


The GUID displayed is the SharePoint 2013/Online Service Instance GUID

The issue occurs when the SmartBox SmartObject contains additional methods from a SharePoint 2013/Online Service Object.
 

 

Resolution

There is a K2 version 4.6.9 coldfix for this issue, please contact K2 Support for more information.