Skip to main content
Nintex Community Menu Bar

[Lab] Building a Process in K2 Studio Designer

  • October 25, 2007
  • 9 replies
  • 24 views

Forum|alt.badge.img+7

I am doing "Step by Step Instructions"-->Lab 1-->Exercise 1-->Step 9.


I completed all other steps, build successfully. But then when I deploy the process, I got error,


(in Output window)
------ Build started: Project: Context-09fa026187874c58b3f6fddb859aa0e0, Configuration: Debug Any CPU ------
Context-09fa026187874c58b3f6fddb859aa0e0 -> C:K2 ProjectsK2 TutorialsProcessDenallix Process TutorialDenallix Process TutorialExtenderProjectsContext-09fa026187874c58b3f6fddb859aa0e0inDebugContext-09fa026187874c58b3f6fddb859aa0e0.dll
------ Build started: Project: Denallix Process Tutorial, Configuration: Debug Any CPU ------
  Denallix Process Tutorial -> C:K2 ProjectsK2 TutorialsProcessDenallix Process TutorialDenallix Process TutorialinDebugDenallix_Process_Tutorial.dll
------ Deploy started: Project: Denallix Process Tutorial, Configuration: Debug Any CPU ------
Warning MSB4056: The MSBuild engine must be called on a single-threaded-apartment. Current threading model is "MTA". Proceeding, but some tasks may not function correctly.
  Task ErrorSystem.NullReferenceException: Object reference not set to an instance of an object.
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.HasPublishedWebsite()
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.Execute()
C:K2 ProjectsK2 TutorialsProcessDenallix Process TutorialDenallix Process TutorialobjDebugDeploymentDenallix Process Tutorial.msbuild(73,5): Error : Task ErrorSystem.NullReferenceException: Object reference not set to an instance of an object.
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.HasPublishedWebsite()
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.Execute()
Done building project "Denallix Process Tutorial.msbuild" -- FAILED.


Build FAILED.
========== Build: 2 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

(in Error List window)
Error 1 Task ErrorSystem.NullReferenceException: Object reference not set to an instance of an object.
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.HasPublishedWebsite()
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.Execute() C:K2 ProjectsK2 TutorialsProcessDenallix Process TutorialDenallix Process TutorialobjDebugDeploymentDenallix Process Tutorial.msbuild
74
6
Denallix Process Tutorial

9 replies

Forum|alt.badge.img+8
  • November 13, 2007

I am also getting the same:


Error 1 Task ErrorSystem.NullReferenceException: Object reference not set to an instance of an object.
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.HasPublishedWebsite()
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.Execute() D:K2VS2005Denallix TrainingDenallix Expense ReportobjDebugDeploymentDenallix Expense Report.msbuild 68 6 Denallix Expense Report


Help will be appreciated, thanks.


Forum|alt.badge.img+11
  • Nintex Employee
  • November 14, 2007

If I remember correctly, this is a confirmed bug in K2 [blackpearl] with HF2.01 - specific to the Forms Generation Events.  I think it is due to development taking place on a machine other than the HostServer machine.  To get around it, you could create a deployment package and execute that (as per one of the KB articles) on the HostServer machine.


This problem will be fixed in the next release.


Regards,


Ockert


Forum|alt.badge.img+4
  • Nintex Partner
  • November 14, 2007

If you are building this on one of the Quickstart Training VPCs (or standalone deployment), try rerunning the Forms Generation wizard. 

On the step where you name the first step, go to the far right of the URL textbox.  You should see something resembling PageName.aspx?[SN=SERIAL_NO].   Delete the page name and the SN = Serial number (everything after the last / ).  Click the [Next >>] button and then click Finish. 

For some reason, on the Training VPCs the forms / site for the forms generated pages are not created the first time through the wizard.  We ran into this in a quickstart today and the steps above fixed the issue for everyone. 

Again, this will only work if you have all of your blackpearl components deployed to a single machine (Standalone).

 


Forum|alt.badge.img+8
  • November 14, 2007

Thanx,


Re-running the wizard did the trick, I don't think it's specific to the Training VPC, I am doing the labs on my own VPC, it must be a small problem with the event template.


 


Forum|alt.badge.img+7
  • Author
  • November 16, 2007
icon-quote.gifmattm:

Again, this will only work if you have all of your blackpearl components deployed to a single machine (Standalone).



Yes, I can run the wizard and deploy without any problem in the Training VPC.

It is the first time I heard that I have to deploy all blackpearl components into a single machine(Standalone) in order to let the Form Generate Wizard works. Is it truth? You were told by K2?


It is a bit.....impossible to deploy all components into same machine, including K2 components for Reporting Service+WSS/MOSS+BP in large firm.  


Forum|alt.badge.img+4
  • Nintex Partner
  • November 16, 2007

I meant that I've encountered this issue, and the fix I suggested works, when using a Standalone environment (as well as the Training VPCs).  I haven't run into the error when deploying to a distributed environment.

You can install the K2 components however you like and use/deploy with Forms Generation wizard.  I have used Forms Gen in a distributed environment and it worked nicely.  I've also deployed to a Standalone and didn't see the error.  I'm not sure why it shows up some Standalone environments and not others.

Sorry if my reply made it sound like Forms Generation will only work in a Standalone setup...that is definitely not the case.  It will work in any environments supported by the K2 installer. 

HTH,

matt 


Forum|alt.badge.img+4
  • November 17, 2007

Hi,


  pls provide me the K2 blackperal Lab practices.otherwise where it available,give me the URL path pls.


 


 


Thanks,


Schand


Forum|alt.badge.img+7
  • Author
  • December 5, 2007
The problem is still not being solved yet.

Forum|alt.badge.img+10
  • Nintex Partner
  • December 6, 2007

You can download the tutorials form the customer partner portal


portal.k2workflow,com