Skip to main content
Nintex Community Menu Bar

KB000305 does not fix anything...

  • October 8, 2008
  • 7 replies
  • 27 views

Forum|alt.badge.img+3

Hi all,

I installed the Hotfix for KB 000305 which is about the worklist which opens every InfoPath form in the client and not in the browser.

After installing the hotfix I got a new error:

Server was unable to process request. ---> List could not be found in specified site. ---> Value does not fall within the expected range

??? Any ideas? (without using reflector creating a "new" working webpart... ;-)

thanks a lot,

marco

7 replies

Forum|alt.badge.img+3
  • Author
  • Nintex Partner
  • October 8, 2008

I've found the bug by myself... It is, because the Worklist WebPart creates the following URLs:

http://dev4:101/RuntimeServices/OpenInfoPathTask.aspx?K2Server=dev4&SN=140_19&XmlFN=Invoicepublished1&Lib=http://dev4:901/Invoicing&OpenAsWebPage=True&SPURL=http://dev4:901&Single=False

But the "Lib=" string has to be relative and not absolute! So it seems, that I have to create a working task list webpart by myself...


Forum|alt.badge.img+9
  • Nintex Partner
  • October 9, 2008

I have managed to replicate your issue on my side and I have already escalated this to our labs.  They are currently busy looking at it.


Sorry for the trouble caused.  I'll update here once I get further info on this.


Forum|alt.badge.img+3
  • Author
  • Nintex Partner
  • October 9, 2008

Thank you very much!

In the meantime I "hacked" the SourceCode.Workflow.RuntimeServices.dll and modified the "AssignValues" method within to trim the "http://domain/" from the "lib" string.

Seems to work, but it would be great if there were an official hotfix...

thanks,

marco


Forum|alt.badge.img+11
  • Nintex Employee
  • October 10, 2008

Hi Guys,


We have resolved this issue by means of a patch which is available from support.  If you do experience this problem, please contact your regional support office for assistance.


Regards,


Ockert


 


Forum|alt.badge.img+9
  • Nintex Partner
  • October 13, 2008

The issue in my case was that the MOSS URL has an extra "/" at the end.  This caused the template to not trim off the server address correctly.  The fix is underway but a workaround at the moment is to specify the MOSS URL without the "/" at the end.


Forum|alt.badge.img+2
  • October 16, 2008
icon-quote.gifOckert:

Hi Guys,


We have resolved this issue by means of a patch which is available from support.  If you do experience this problem, please contact your regional support office for assistance.


Regards,


Ockert


 

Hi guys

I've contacted the support, applied the patch, and redeployed the process, but I stilll get the same error.

Do I need to resume from scratch my InfoPath form ?

Regards,


Forum|alt.badge.img
  • December 30, 2008

Thanks for the post