Skip to main content
Nintex Community Menu Bar

K2 Server CPU sustaining at 99.9999% Utilization

  • November 4, 2015
  • 0 replies
  • 11 views

Forum|alt.badge.img+9


 

Symptoms


K2 blackpearl application server CPU staying at 99.999% utilization.
Users are either unable to load their worklist at all, or it is extremely slow. Sometimes, they receive timeout errors when the worklist fails to load.
 

Diagnoses


High CPU utilization is often caused by process instances stuck in a Running state.
Another likely cause of high utilization is overly aggressive refresh settings for the Identity Service. In this case, the UserCacheTimeout setting was configured to be 15 minutes, rather than the default of 8 hours. This meant that every Identity in the Identity Cache was being marked to refresh every 15 minutes.
The Identity Service, by default, looks at the cache every 10 minutes, and re-caches information about every expired identity.
Further information on performance of the K2 Identity Service can be found here:
http://help.k2.com/onlinehelp/K2blackpearl/ICG/4.6.11/webframe.html_Tweaking_identity_cache_performance_for_the_K2_Server.html
 

Resolution

Increase the timeout interval using the following SQL script:

USE K2
UPDATE [K2].[Identity].[CacheConfiguration]
SET Value = '4h'
WHERE Name = 'UserCacheTimeout'