Skip to main content


 

Symptoms


Issue:
The client was unable to access worklist items through the K2 mobile App on Android.

 

Diagnoses


Diagnosis:
We tested this on IOS and found that the work list was accessible. We were assisted by K2 mobile developers and found that there seems to be issue with the authentication.
 

Resolution

Resolution:

We were advised by the mobile development team and the findings were as follows

For temporary solution the client can switch off windows authentication that will on normal HTTP protocols send username and password in plain text. But as this is a secure https connection the connection stays secure.

The permanent and more secure resolution used by other client to resolve this issue was to setup kerberos authentication for IIS hat can be done by following this Microsoft guide :

https://blogs.msdn.microsoft.com/chiranth/2014/04/17/setting-up-kerberos-authentication-for-a-website-in-iis/




 
Be the first to reply!

Reply