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Symptoms

 

When packaging a K2 for SharePoint/Appit solution you might run into an issue like the following:

 

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Diagnosis

 

This issue can be related to the following scenarios:

 

 

 

#1. The list has been renamed and so have all the K2 artifacts. The workflow did not pick up the new forms. 

 

#2. There is a live workflow on the workflow server that is still referencing the older forms. 




 

Solution

 

To resolve these issues it is actually very simple.

 

 

 

#1. Open the workflow and run through the start rule wizard. Re-select the correct form and finish out the wizard. It might be helpful to select a different form, then select the correct one to make sure all the references are cleared out. Re-deploy the workflow and try to package the solution again. You shouldn't see the error anymore. If you do, look at #2.

 

 

 

#2. To see if our issue is due to a live workflow/older workflow, we can check the name of the workflow it is complaining about in the error. If this is our older workflow name, it means it still exists on the workflow server. This can happen very easily if a list is renamed. The Workflow on the Workflow Server is the old name before the list rename. Package and deploy tries to grab this workflow still, even though we have a new, renamed workflow. 

 

To resolve, simply delete the workflow from K2 Management > Workflow Server. Delete all versions and get rid of the logging data for it as well. Re-package the solution and you shouldn't have that error.

 

 

 

NOTE: This assumes that the old workflow, all active instances and all historical data for completed instances is no longer needed.  If this data is needed, DO NOT delete the workflow definition.



 
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