Skip to main content
Nintex Community Menu Bar

K2 4.6.9 smartforms Setup Manager freezes during configuration stage

  • November 11, 2016
  • 0 replies
  • 8 views

Forum|alt.badge.img+11


 

Symptoms

 


K2 4.6.9 smartforms Setup Manager freezes during configuration stage on the applying your configuration settings stage with status "Start Host Server", K2 host server log contains the following errors:

 

 

 

"Error","System","2025","InternalMarshalError","SourceCode.Hosting.Server.Runtime.HostServerBroker.InternalMarshal","2025 Error Marshalling SourceCode.Deployment.Runtime.DeploymentServer.Send, Member 'ItemId' was not found."
 

 

Diagnoses

 


Error from host server log indicates that version of K2 older than 4.6.11 (e.g. 4.6.9) is installed on a Windows Server with .NET 4.6.x installed. Versions of K2 older than 4.6.11 do not support .NET 4.6 and work with .NET Framework 4.0/4.5 (RTM). Please refer to K2 compatibility matrix for details: http://help.k2.com/blackpearl/support-matrix#NET

 

 

 

To fix this problem you either have to use K2 4.6.11 or newer or remove .NET 4.6 by removing corresponding windows update package either via GUI Programs and Features > View Installed Updates or via command line:

 

wusa.exe /uninstall /KB:%hotfixID% /quiet /norestart

 

 

 

Problem can be resolved by removing .NET 4.6.1/KB3102467. Depending on your base OS an exact .NET 4.6 version installed you may also have to remove KB3045563.
 

 

Resolution

Problem can be resolved by removing .NET 4.6.1/KB3102467. Depending on your base OS an exact .NET 4.6 version installed you may also have to remove KB3045563.