Skip to main content
Nintex Community Menu Bar

Issues while setting up the environmental variable for K2

  • November 12, 2015
  • 0 replies
  • 5 views

Albarghouthy
Forum|alt.badge.img+16


 

Symptoms

 


Issues while setting up the environmental variable for K2
 

 

Diagnoses

 


Issues while setting up the environmental variable for K2.

Below are the steps

1. Log on the machine- IP

 

2. Traverse to K2 Black pearl through Start menu.
3. Open up the K2 Black pearl Workspace
4. Go to Management and select option ‘Management Console’.
5. Collapse the Machine by clicking on ( ) icon.
6. Collapse Environment Library->Templates->Template Fields
7. I was trying to add the Environmental variables by clicking on ‘ADD’ button on top.
8. Post adding, I was unable to view the added variable.
9. Tried looking at the environments, I'm getting the following error:
"Primary Credentials not authenticated"


 

 

Resolution

I have checked the "Hostserver.SecurityLable" to make sure that the domains are configured correctly in Roleinit and AuthInit columns, the domain and configured properly
For more info (http://help.k2.com/kb000182)

The issue was resolved by doing the following:

Go to IIS Managed > Workspace site > Authentication > Enable ASP.Net Impersonation.