Symptoms
Installation errors as well as errors trying to load K2 Workspace
Diagnoses
After completing the K2 installation for Blackpearl, there are multiple messages being displayed on the performance counter, and file system permissions as well.
Furthermore you are not able to navigate to K2 Workspace.
Initialization failed before PreInit: Error:
Please verify that all necessary scripts were run and review the error logs
Possible causes
- using anonymous logon in IIS while Windows security is specified in Workspace configuration.
- current logged on user can not be verified against the Active Directory Membership provider.
- please review log files for more information.
Resolution
In regards to the folder permissions this can be ignored as long as you confirm that the service account has permissions to the file system folders in question with the correct rights.
In regards to the K2 Workspace error:
To resolve this you can start by looking at the workspace web config file which can be located in the following directory:
Program Files (X86) >>> K2 Blackpearl >>> Workspace >>> site >>> web.config
Even though the LDAP path may seem correct here this will have to be changed so it actually points to the domain controller itself.
This was changed from:
To
<
After doing this, do an IIS reset and restart the K2 service.
After this you should see K2 Workspace load as normal.