Skip to main content
Nintex Community Menu Bar

Initialization failed before PreInit for some users when accessing K2 workspace

  • November 10, 2015
  • 0 replies
  • 20 views

Forum|alt.badge.img+18


 

Symptoms


When accessing K2 Workspace, for some accounts it is erring with:

An error has occurred.
Please contact your administrator.
Error:
Initialization failed before PreInit: Error:
Please verify that all necessary scripts were run and review the error logs
Possible causes
- using anonymous logon in IIS while Windows security is specified in Workspace configuration.
- current logged on user can not be verified against the Active Directory Membership provider.
- please review log files for more information.
 

Diagnoses


There were entries in the [Workspace].[UserProfile] table in which the UserID column was blank.
 

Resolution

Removing the row where the 'UserID' was blank and having the affected users retry K2 Workspace resolved the error.