Symptoms
Issue:
Managed to install the latest version 4.6.11 on our live system. We are now struggling with the refresh of user identity. Some people can access without problems, other users get the following error:
24408 XX:XXXXXXXXX From XX.XXX.XX.XX:XX does not have rights to Start Process XXXXXX_XXXXXXX_XX_XXX
Diagnoses
Diagnosis:
1. The client had shown us the identity.Identity table where it was seen the affected user was enabled and Validated that the domain/group that the user is part of is active and valid
2. Tested another user but this was found that the user did not have the right permissions - after granting the user permissions they were able to access the workflow.
3. Tested the theory of adding the user individually to the workflow process rights- this allowed the user to open the workflow
4. Thereafter removed the user from the process rights as the group user is part of has rights to the process
5. Ran the identity refresh script for the affected user within the identity.identity table.
Resolution
Resolution:
Using the Identity Refresh Script , refresh the affected users and the users were no longer receiving the initial error.
Please contact K2 support for assistance with obtaining the script.