Skip to main content
Nintex Community Menu Bar

Fail to deploy workflow - The "SourceCode.SharePoint15.DeploymentTask.Task" task failed unexpectedly

  • August 21, 2015
  • 1 reply
  • 15 views

Forum|alt.badge.img+16


 

Symptoms


I am having an issues deploying workflows to both dev and test environments. This appears to be user / computer specific. I am betting I am missing a permission or installation file. I am hoping that you have seen this many times before. When deploying K2 for SharePoint 2013 integrated workflow, the deployment fails with the error message.

1 Error(s)
(K2_ProjectK2_Process_Name) The "SourceCode.SharePoint15.DeploymentTask.Task" task failed unexpectedly.
System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.SharePoint.Client, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.
File name: 'Microsoft.SharePoint.Client, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'
at SourceCode.SharePoint15.DeploymentTask.Task.CollectTaskResources()
at SourceCode.SharePoint15.DeploymentTask.Task.Execute()
at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
at Microsoft.Build.BackEnd.TaskBuilder.d__20.MoveNext()

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLMSoftwareMicrosoftFusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLMSoftwareMicrosoftFusion!EnableLog].

0 Warnings(s)
 

Diagnoses


SharePoint Client Components Redistributable is failing to install by K2 Setup Manager. Apparently, the K2 Setup Manager will proceed without any warnings and the installed log file from %temp% folder doesn’t reveal any additional information.
 

Resolution

Issue was resolved per following steps below:
-Navigate to the K2 for SharePoint installer directory on your machine (i.e. Installer_Directory K2 Blackpearl SoftwaresK2 Installation Package 4.6.9K2 for SharePoint 4.6.9 (4.13350.1660.1)InstallationRedistributable).
-Install the x64 bit component. Try to deploy the workflow again.




 

1 reply

Forum|alt.badge.img+2

This solution is not working for me. Could you provide more context into where this file should be deployed?