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Symptoms

 


When trying to deploy a very simple workflow with a Send meeting request from K2 Designer for SharePoint the following error is being thrown error:


Failed to compile - With no errors. Contact system administrator.
 

 

Diagnoses

 


DIAGNOSIS
K2 host server log does not contain any errors which correlate with this error, but if you try to deploy the same workflow from K2 Studio you may get the following error:

bExchangeCalendar] could not be found

This error is clear indication that K2 Exchange Integration SmartObjects were not created during on K2 server during installation. In order to additionally confirm this you may use "Smart Object Services Tester Tool" which can be found in the following location: " nProgram Files (x86)]K2 blackpearlBinSmartObject Service Tester.exe" Specifically for meeting requests you should have Exchange Calendar SmartObject with New Meeting and New Appointment methods.

Most likely this issue was caused by missing integration prerequisites for K2 Exchange Integration. If prerequisites are missing during installation related SmartObjects may not be created by K2 installer. Prerequisites differ depending on version of Exchange.

Microsoft Exchange 2007 (SP2 or SP3):
Exchange Management Tools

Microsoft Exchange Server 2010:
Windows Powershell v3
WinRM (Windows Remote Management)

Please refer to the following K2 KB article for details:
"How To: Working with K2 Exchange Integration"
And the following section of "K2 blackpearl Installation and Configuration Guide":
http://help.k2.com/onlinehelp/K2blackpearl/ICG/4.6.11/webframe.html_Integration.html

Make sure that prerequisites in place and re-run K2 installer. Another possibility is that required integration options just were not selected during installation (checkbox "Enable standard exchange integration (Calendar, Meeting)"), refer to the following section of the help.k2.com:
http://help.k2.com/onlinehelp/K2blackpearl/ICG/4.6.11/webframe.html_Exchange_Integration.html
 

 

Resolution

Make sure that prerequisites are in place and re-run K2 Setup Manager from installation media (not from the Start menu) and make sure that checkbox "Enable standard exchange integration (Calendar, Meeting) is selected.

See also the following community KB:
How to use "send meeting request" in K2 workflow

 

 



 
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